在线检测未来函数

通达信MACD变异指标公式

来源:Internet,编辑:股旁网,2013-10-31

WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
XYS0:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
STICKLINE(XYS0>=0,XYS0,0,2,0),COLORRED;
STICKLINE(XYS0<0,XYS0,0,2,0),COLORGREEN;
HD:=FILTER(BACKSET(XYS0>0 AND XYS0<REF(XYS0,1) AND REF(XYS0,1)>REF(XYS0,2),2),1);
DRAWLINE(HD,XYS0,REF(HD,1),REF(XYS0,1),1);
LD:=FILTER(BACKSET(XYS0<0 AND XYS0>REF(XYS0,1) AND REF(XYS0,1)<REF(XYS0,2),2),1);
DRAWLINE(LD,XYS0,REF(LD,1),REF(XYS0,1),1);
PJGJ:=AMOUNT/AMO/100;
SSRYDJX:=MA(PJGJ,13);
SSRCJL:=EMA(AMO,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=SSRCJE/SSRCJL/100;
CYS13:=(CLOSE-SSRCBJX)/SSRCBJX*100;
XYSHSL:=EMA(AMO/CAPITAL*100,13);
ZZX:0,COLORWHITE;
{STICKLINE(XYSHSL>6.1 AND CYS13>5,2,0,2,0),COLORGREEN;
STICKLINE(XYSHSL>3.8 AND CYS13>5,1.5,0,2,0),COLORYELLOW;
STICKLINE(XYSHSL>2.1 AND CYS13>5,1,0,2,0),COLORCYAN;
STICKLINE(XYSHSL>1.8 AND CYS13>5,0.5,0,2,0),COLORBLUE;}
XYS1:MA(XYS0,2);
XYS2:MA(XYS0,1);
DRAWICON(CROSS(XYS2,XYS1),XYS0,11);
DRAWICON(CROSS(XYS1,XYS2),XYS0,15);

通达信MACD变异指标公式

 

相关文章