在线检测未来函数

大智慧帝式主图指标公式

来源:Internet,编辑:股旁网,2013-11-04

K:=5;
T := BARSLAST(DISPSTATUS=1)+1;
A := DISPSTATUS=2;
HH := HHV(H, T);
LL := LLV(L, T);
HL := HH-LL;
wH := HHVBARS(H, T);
wL := LLVBARS(L, T);
KK := wH-wL;
mHL := HH-HL*0.5;
if K=1 then begin
HL191 := (HH-LL)*0.191;
HL382 := (HH-LL)*0.382;
HL618 := (HH-LL)*0.618;
HL809 := (HH-LL)*0.809;
if KK<0 then begin
a1 := HH-HL191;
a2 := HH-HL382;
a3 := HH-HL618;
a4 := HH-HL809;
end else begin
a1 := LL+HL191;
a2 := LL+HL382;
a3 := LL+HL618;
a4 := LL+HL809;
end
end
if k=1 then begin
HL125 := (HH-LL)*0.125;
HL250 := (HH-LL)*0.25;
HL375 := (HH-LL)*0.375;
HL625 := (HH-LL)*0.625;
HL750 := (HH-LL)*0.75;
HL875 := (HH-LL)*0.875;
if kk<0 then begin
b1 := HH-HL125;
b2 := HH-HL250;
b3 := HH-HL375;
b4 := HH-HL625;
b5 := HH-HL750;
b6 := HH-HL875;
end else begin
b1 := LL+HL125;
b2 := LL+HL250;
b3 := LL+HL375;
b4 := LL+HL625;
b5 := LL+HL750;
b6 := LL+HL875;
end
end
DRAWTEXT(A and K<>3,HH, ' 最高价:'+HH),ALIGN2,colorgreen;
DRAWTEXT(A and K<>3,LL, ' 最低价:'+ll),ALIGN2,VALIGN2,colorgreen;
DRAWTEXT(A and K<>3,mHL,' 50%:'+mHL),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a1, ' 0.191:'+NUMTOSTRN(a1,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a2, ' 0.382:'+NUMTOSTRN(a2,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a3, ' 0.618:'+NUMTOSTRN(a3,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a4, ' 0.809:'+NUMTOSTRN(a4,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, b1, ' 1/8:'+NUMTOSTRN(b1,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b2, ' 1/4:'+NUMTOSTRN(b2,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b3, ' 3/8:'+NUMTOSTRN(b3,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b4, ' 5/8:'+NUMTOSTRN(b4,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b5, ' 3/4:'+NUMTOSTRN(b5,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b6, ' 7/8:'+NUMTOSTRN(b6,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K<>3,HH, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,LL, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K<>3,mHL,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,colorff0000,linethick7;
DRAWTEXT(A and K=1, a1, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a2, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a3, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a4, '﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, b1, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00FF00;
DRAWTEXT(A and K=1, b2, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b3, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b4, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b5, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b6, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,color00FF00;
G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
X:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
ED:=barslast(G);
EF:=barslast(X);
买入到卖出天数:ED,LINETHICK0,ColorFFFFFF;
卖出到买入天数:EF,LINETHICK0,ColorFFFFFF;
换手: VOL/CAPITAL*100,LINETHICK0,colorwhite;
DRAWTEXTREL(0,910,' 买入到到当前周期:'+NUMTOSTR(ED) +'天'+' 卖出到当前周期:'+NUMTOSTR(EF) +'天'+' 换手率:'+NUMTOSTRN(换手,2) +'%' ),colorFfff00;

大智慧帝式主图指标公式

 

相关文章