在线检测未来函数

通达信MACD和±均差指标公式

来源:Internet,编辑:股旁网,2013-11-12

N:=3;
N1:=5;
N2:=7;
N3:=9;
N4:=13;
反均差:=((MA(CLOSE,N4)-MA(CLOSE,N3))/C);
正均差:=((MA(CLOSE,N3)-MA(CLOSE,N4))/C);
平滑均差:=MA(正均差,N2),COLORYELLOW;
正均差柱体:(正均差-平滑均差)*20,COLORSTICK;
负均差柱体:-(反均差-平滑均差)*20,COLORGREEN;
DIF:=(MA(CLOSE,24)-MA(CLOSE,52))/C*V;
DEA:=MA(DIF,9);
MACD:=(DIF-DEA)/20;
DRAWICON(负均差柱体<-0.5 AND C<(REF(C,1)*0.981),0,1);
STICKLINE(C>0,-0.6,-0.9,2,0),COLORWHITE;
STICKLINE(负均差柱体>DEA AND 负均差柱体<0 AND DEA>DIF,-0.5,-1,2,0),COLORLIRED;
STICKLINE(负均差柱体>DEA AND 负均差柱体>0 AND DEA<DIF,-0.5,-1,2,0),COLORRED;
STICKLINE(负均差柱体<DEA AND 负均差柱体<0 AND DEA>DIF,-0.5,-1,2,0),COLORGREEN;
STICKLINE(负均差柱体<DEA AND 负均差柱体>0 AND DEA<DIF,-0.5,-1,2,0),COLORLIBLUE;

通达信MACD和±均差指标公式

 

相关文章