在线检测未来函数

飞狐独门暗器指标公式

来源:Internet,编辑:股旁网,2013-11-14

input:P(15,1,50),N(-10,-50,0);
VAR1:=IF(((YEAR >= 9999) AND (MONTH > 0)),0,1);
VAR2:=LLV(LOW,18);
VAR3:=HHV(HIGH,18);
VAR4:=EMA((((CLOSE - VAR2) / (VAR3 - VAR2)) * 100),13);
VAR5:=(EMA(((0.618 * REF(VAR4,1)) + (0.382 * VAR4)),3) * VAR1);
STICKLINE(((VAR5 - REF(VAR5,1)) > 0),VAR5,VAR5,1,0);
STICKLINE(((VAR5 - REF(VAR5,1)) < 0),VAR5,VAR5,1,0);
VAR6:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR7:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR8:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR9:=(((VAR6 + (2 * VAR7)) + (3 * VAR8)) / 6);
IF(CROSS(80,VAR5),80,100);
VARA:=MA(VAR9,3);
独门暗器:IF((VARA < N),15,0);
15;
45;

飞狐独门暗器指标公式

 

相关文章