在线检测未来函数

通达信周KDJ模拟双波段指标公式

来源:Internet,编辑:股旁网,2013-11-17

周N:=WEEKDAY;
周HIGH:=IF(WEEKDAY=周N,HHV(H,4),0);
周LOW:=IF(WEEKDAY=周N,LLV(L,4),0);
周CLOSE:=IF(WEEKDAY=周N,CLOSE,0);
周RSV:=(周CLOSE-LLV(周LOW,45))/(HHV(周HIGH,45)-LLV(周LOW,45))*100;
周K:SMA(周RSV,3,1),COLORWHITE ;
周D:SMA(周K,3,1),COLORYELLOW ;
周J:3*周K-2*周D,COLORRED ;
DRAWBAND(周K,RGB(255,0,0),周D,RGB(0,255,0));
D1:=1;
DRAWTEXT_FIX(D1=1,0,0,0,'本指标通过模拟跨周期WEEK函数在日线周期中的调用情况来实现了连续显示,并去除了WEEK函数的未来性质。'),COLORWHITE;
DRAWTEXT_FIX(D1=1,0,0.05,0,'较明亮的显示为周KDJ的模拟显示,详情参见http://www.55188.com/thread-5494076-1-1.html'),COLORWHITE;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE ;
D:SMA(K,3,1),COLORYELLOW ;
J:3*K-2*D,COLORMAGENTA ;
DRAWBAND(K,RGB(168,18,38),D,RGB(10,100,200));

通达信周KDJ模拟双波段指标公式

 

相关文章