在线检测未来函数

通达信毁三观主图指标公式

来源:Internet,编辑:股旁网,2013-12-04

N:=14;
{区域}
STICKLINE(CLOSE> REF(CLOSE,1) ,DHIGH,DLOW,4.1,0 ),COLOR004080;
STICKLINE(CLOSE< REF(CLOSE,1) ,DHIGH,DLOW,4.1,0 ),COLOR800000;
BT34:=IF(BACKSET(BARSTATUS=2,34)=1,1,DRAWNULL);
近本: BT34*SUM(AMOUNT,13)/SUM(VOL,13)/100,LINETHICK2,COLORBLUE;
{原始人毁三观指标&预警}
{常规条件}
常规条件A:=((EXIST(CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH,13) OR EXIST(((CLOSE-LLV(CLOSE,5))/LLV(CLOSE,5)*100)>10,13))) AND HHV(HIGH,34)!=HIGH;
常规条件B:=IF(BARSTATUS=2,VOL/FROMOPEN>(REF(VOL,1)+REF(VOL,2))/480,VOL>(REF(VOL,1)+REF(VOL,2))/2);
{毁三观指标}
DD:=BARSLAST(DOPEN=REF(DOPEN,1) AND DHIGH=REF(DHIGH,1) AND DLOW=REF(DLOW,1) AND DCLOSE=REF(DCLOSE,1));
DDT1:=BARSLAST(DD=1);
现重:SUM(AMOUNT,DDT1+1)/SUM(VOL,DDT1+1)/100,NODRAW;
前重:REF(现重,DDT1+1),NODRAW;
前2重:REF(前重,DDT1+1),NODRAW;
前3波:=REF(前2重,DDT1+1);
前4波:=REF(前3波,DDT1+1);
前5波:=REF(前4波,DDT1+1);
前6波:=REF(前5波,DDT1+1);
前7波:=REF(前6波,DDT1+1);
波段MAX:=MAX(前重,MAX(前2重,MAX(前3波,MAX(前4波,MAX(前5波,MAX(前6波,前7波))))));
BB1:=波段MAX=前重;
BB2:=波段MAX=前2重;
BB3:=波段MAX=前3波;
BB4:=波段MAX=前4波;
BB5:=波段MAX=前5波;
BB6:=波段MAX=前6波;
BB7:=波段MAX=前7波;
AA1:=IF(BB1=1,0,前重);
AA2:=IF(BB2=1,0,前2重);
AA3:=IF(BB3=1,0,前3波);
AA4:=IF(BB4=1,0,前4波);
AA5:=IF(BB5=1,0,前5波);
AA6:=IF(BB6=1,0,前6波);
AA7:=IF(BB7=1,0,前7波);
波段MAX2:=MAX(AA1,MAX(AA2,MAX(AA3,MAX(AA4,MAX(AA5,MAX(AA6,AA7))))));
波段MIN:=MIN(前重,MIN(前2重,MIN(前3波,前4波)));
波段趋势:=(((前重>前2重)+(前2重>前3波)+(前3波>前4波))>=2 AND DLOW>波段MIN) OR DHIGH>波段MAX2;
快速K线:=HIGH>波段MAX2;
{指标预警}
D条件A:=CLOSE>OPEN AND DCLOSE>DOPEN AND 波段趋势=1 AND 快速K线 AND (EXIST(DCLOSE<DOPEN,4) OR EXIST(CLOSE<OPEN,4)) AND 常规条件A AND 常规条件B;
D条件B:=(DCLOSE-REF(CLOSE,4))/REF(CLOSE,4)*100;
警X: D条件A OR CROSS(D条件B,20),COLORYELLOW,NODRAW;
{画K线}
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCC66FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
STICKLINE(波段趋势=1,前重,前重,10,0),COLORFFFF00;
DRAWTEXT(D条件A OR CROSS(D条件B,20),DLOW*0.97,'↖买'),COLORYELLOW;

通达信毁三观主图指标公式

 

相关文章