在线检测未来函数

通达信玩转KDJ指标公式

来源:Internet,编辑:股旁网,2013-12-07

{坐标线位置:0.00;20.00;40.00;50.00;60.00;85.00}
105,COLORFF7F00,DOTLINE;
{极品RSI优化}
LC1:= SMA(C,2,1);
TCRSI:=SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100;
LC2:= SMA(H,2,1);
THRSI:=SMA(MAX(H-LC2,0),6,1)/SMA(ABS(H-LC2),6,1)*100;
LC3:= SMA(O,2,1);
TORSI:=SMA(MAX(O-LC3,0),6,1)/SMA(ABS(O-LC3),6,1)*100;
LC4:= SMA(L,2,1);
TLRSI:=SMA(MAX(L-LC4,0),6,1)/SMA(ABS(L-LC4),6,1)*100;
TVAR:=SMA(((10000 * CLOSE) / INDEXC),2,1);
大盘关联』:=SMA(MAX(((10000 * CLOSE) / INDEXC)-TVAR,0),6,1)/SMA(ABS(((10000 * CLOSE) / INDEXC)-TVAR),6,1)*100;
RSI:=(TCRSI+TORSI+THRSI+TLRSI+『大盘关联』)/5,COLORMAGENTA,LINETHICK1;
参考线:=EMA(EMA(RSI,6),5),COLORGRAY,LINETHICK1;
中轨:=MA(RSI,26);
STICKLINE(CROSS(参考线,中轨),95,105,1.2,0),COLORRED;
STICKLINE(CROSS(参考线,中轨),85,95,1.2,0),COLORGREEN;
DRAWTEXT(CROSS(参考线,中轨),104.5,'卖↑'),COLORGREEN,LINETHICK1;
DRAWTEXT(CROSS(参考线,中轨),94.5,'买↓'),COLORRED,LINETHICK1;
60,COLORLIRED,DOTLINE;
DRAWTEXT(ISLASTBAR,65,'↑强'),COLORRED;
{一三买入法}
MA10:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
{倍量表示:今日大于昨日2倍量}
VOLUME:=VOL;
TJ:=(V/REF(V,1)>3.4) AND MA10<MA34 AND MA10>REF(MA10,1);
三连阴:=LAST(C<O,3,0);
三缩量:=LAST(VOL<REF(VOL,1),3,0);
选股:=REF(三连阴,1)>0 AND REF(三缩量,1)>0 AND O<C AND TJ;
STICKLINE(选股,0,40,1.2,0),COLORRED;
DRAWTEXT(选股>0.9,39,' 抢'),COLORRED,LINETHICK1;
DRAWTEXT(选股>0.9,27,' 反'),COLORRED,LINETHICK1;
DRAWTEXT(选股>0.9,15,' 弹'),COLORRED,LINETHICK1;
{盘整突破}
VARR:=(C+H+O+L)/4;
上轨:=EMA(VARR,10)*1.09;
盘整突破:=LAST((H-L)/REF(C,1)<0.1,20,0) AND VOL>REF(VOL,1)*1.5 AND C>REF(C,1)*1.03
AND "DMI.PDI">"DMI.MDI" AND"DMI.ADXR">"DMI.MDI"AND "DMI.PDI">"DMI.ADX"
AND(CROSS("DMI.ADX","DMI.ADXR")OR("DMI.ADX">"DMI.ADXR"))
AND"KDJ.D">REF("KDJ.D",1) AND"KDJ.D"<75 AND C<上轨;
STICKLINE(盘整突破,25,35,1.2,0),COLORGREEN;
STICKLINE(盘整突破,15,25,1.2,0),COLORA943FF;
STICKLINE(盘整突破,0,15,1.2,0),COLORRED;
DRAWTEXT(盘整突破,35,' 卖'),COLORGREEN,LINETHICK1;
DRAWTEXT(盘整突破,24,' 破'),COLORA943FF,LINETHICK1;
DRAWTEXT(盘整突破,13.5,' 突'),COLORRED,LINETHICK1;
{财神到}
XXBB:= EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*4,5)*100;
财神到:=REF(XXBB,1)<50 AND XXBB-REF(XXBB,1)>25;
STICKLINE(财神到,70,80,1.2,0),COLOR2222AA;
STICKLINE(财神到,60,70,1.2,0),COLOR11AA88;
STICKLINE(财神到,50,60,1.2,0),COLORAAAA00;
DRAWTEXT(财神到,80,'财'),COLOR00FFFF,LINETHICK1;
DRAWTEXT(财神到,70,'神'),COLOR00FFFF,LINETHICK1;
DRAWTEXT(财神到,60,'到'),COLOR00FFFF,LINETHICK1;
{爆点}
爆点:=LLV(L,3)=LLV(L,60) AND C/REF(C,1)>=1.04;
I爆点:STICKLINE(爆点,0,35,1.2,0),COLORLIRED,LINETHICK1;
DRAWTEXT(爆点,32,'爆点'),COLOR00FFFF,LINETHICK1;
{爆点卖注:除当日涨停外,第二天集合竞价或开盘冲高即卖}
{大底后抄底}
{铁底}
VAR34:=EMA(AMOUNT/VOL/100,3);
伏击线:=EMA(VAR34,88)*0.85;
走势铁底:=伏击线*0.87;
VAR35:=LOW<=走势铁底 AND CLOSE>REF(CLOSE,1)*1.02;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
X1:=EMA(DIFF,5)*5;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
X3:=CROSS(X2,X1) AND X1<-0.25 AND (REF(C,20)-C)/C>0.30;
大底后抄底:=X3 AND VAR35;
STICKLINE(大底后抄底,0,23,1.2,0),COLOR00FFFF;
DRAWTEXT(大底后抄底,20,'抄底'),COLOR00FFFF,LINETHICK1;
{主力进场}
涨幅%:=(C-REF(C,1))/REF(C,1)*100,LINETHICK0;
条件2:=(涨幅%>6 AND 涨幅%<7) AND VAR35 AND 爆点 AND X3;
B11:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B12:=SMA(B11,9,1)+100;
B13:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B14:=SMA(B13,3,1);
B15:=SMA(B14,3,1)+100;
B16:=B15-B12;
观望期:=IF(B16>60,B16-60,0);
IF(REF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04 AND 观望期=0 AND C>REF(C,1),1)
AND 条件2,70,50),LINETHICK2,COLORCYAN;{进}
DRAWTEXT(REF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04 AND 观望期=0 AND C>REF(C,1),1)
AND 条件2,75,'主力进场'),COLORCYAN,LINETHICK1;
50,COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,55,'↓弱'),COLORGREEN;
{爆点淑女宣选股}
{淑女宣}
左手:=C-REF(C,1);
秋天:=100*EMA(EMA(左手,6),6)/EMA(EMA(ABS(左手),6),6);
梦想:=LLV(秋天,2)=LLV(秋天,7) AND COUNT(秋天<0,2) AND CROSS(秋天,MA(秋天,2));
十三:=FINANCE(37)<=60000;
十三的思想:=(C-REF(C,20))/REF(C,20)*100<0;
淑女宣:=FILTER(梦想=1,5) AND CCI>0 AND 十三 AND 十三的思想;
STICKLINE(淑女宣,0,23,1.2,0),COLORGREEN;
DRAWTEXT(淑女宣,20,' 淑女'),COLORGREEN,LINETHICK1;
{天天抓涨停}
熊五:=MA(CLOSE,5);
生命线:=EXPMA(EXPMA(CLOSE,50),1);
B1:=熊五>生命线 AND 生命线>REF(生命线,1);
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
天天抓涨停:=FILTER(VAR327>1,5) AND B1;
IF(天天抓涨停>0,40,0),COLORMAGENTA,LINETHICK2;
DRAWTEXT(天天抓涨停>0,38,'抓涨停'),COLORMAGENTA,LINETHICK1;
{今买明卖}
MA20:=MA(C,20);
MA30:=MA(C,30);
QSXS:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
ZF:=(C/REF(C,1)-1)*100;
N1:=BARSLAST(CROSS(C,MA(C,5)));
N2:=BARSLAST(CROSS(MA(C,5),C));
HM:=IF(N1<N2,N1+1,0)*QSXS;
Z2:=HM=1 AND ZF>=0 AND C>O AND QSXS;
KX1:=ZF<=-3 AND C<O;
XDSJ:=BARSLAST(KX1);
KX2:=ZF>=3 AND C>O;
JBY:=KX2 AND XDSJ<=2 AND C>=REF(O*0.99,XDSJ) AND ZF>ABS(REF(ZF,XDSJ)*0.99);
Z3:=IF(FILTER(JBY,1) AND QSXS,5,0);
今买明卖:=Z2 AND Z3;
IF(今买明卖,25,0),LINETHICK2,COLORGREEN;
DRAWTEXT(今买明卖>0,20,'买卖'),LINETHICK1,COLORGREEN;
{KDJ}
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
快线2:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:=SMA(快线2,3,1),COLOR00FFFF,LINETHICK2;
{J线没未来}
快线1:3*快线2-2*D,COLOR00FFFF,LINETHICK2;
IF(快线1<REF(快线1,1),快线1,DRAWNULL),COLORGREEN,LINETHICK2;
IF(快线1>REF(快线1,1),快线1,DRAWNULL),COLORRED,LINETHICK2;
{买进}
牛十:=MA(CLOSE,10);
B2:=快线1<35 AND 熊五<牛十;
A5:=C-REF(C,1);
A6:=100*EMA(EMA(A5,6),6)/EMA(EMA(ABS(A5),6),6);
RMA1:=EMA(CLOSE,7);
NMA1:=EMA(CLOSE,19);
UP1:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),H
=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),0);
DOWN1:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),L
=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),0);
买进:=(LLV(A6,2)=LLV(A6,7) AND COUNT(A6<0,2) AND CROSS(A6,MA(A6,2))) AND
REF(DOWN1,1)<REF(DOWN1,2) AND UP1>REF(DOWN1,1) AND B2;
STICKLINE(买进,85,105,1.2,0),COLORMAGENTA;
DRAWTEXT(买进,104.5,'买'),COLORMAGENTA,LINETHICK1;
DRAWTEXT(买进,94.5,'进'),COLORMAGENTA,LINETHICK1;
20,COLOR4080FF,DOTLINE;
DRAWTEXT(ISLASTBAR,25,'关注'),COLOR4080FF;
40,COLOR00FFFF,LINETHICK3,POINTDOT;
85,COLORA943FF,DOTLINE;
{钱袋显示}
AHC3:=EXPMA(CLOSE,9);
外下:=EXPMA(AHC3*0.86,5),COLOR00FFFF,DOTLINE;
DZ:=MIN(C,O)<MA(C,5) AND (MIN(C,O)-L)/O>0.05;
DRAWICON(DZ AND L< 外下,L*0.98,9);{钱袋显示};

通达信玩转KDJ指标公式

 

相关文章