在线检测未来函数

通达信真正完全换手指标公式

来源:Internet,编辑:股旁网,2013-12-15

年:=2013;
月:=1;
日:=1;
{参数设置 年:1990,3000,2011 月:1,12,1 日:1,31,1}
时间:=(年-1900)*10000+月*100+日;
{DRAWTEXT(BARSLAST(DATE<=时间),L*0.95,'换手起点'),COLORRED;
DRAWICON(BARSLAST(DATE<=时间),L*0.96,23)};
HSL:=100*VOL/(FINANCE(7)/100),NODRAW;
GG:=SUM(HSL,BARSLAST(DATE<=时间));
换手1次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=100,DRAWNULL);
换手2次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=200,DRAWNULL);
换手3次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=300,DRAWNULL);
换手4次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=400,DRAWNULL);
换手5次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=500,DRAWNULL);
换手6次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=600,DRAWNULL);
换手7次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=700,DRAWNULL);
换手8次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=800,DRAWNULL);
换手9次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=900,DRAWNULL);
换手10次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=1000,DRAWNULL);
换手11次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=1100,DRAWNULL);
换手12次:=IF(DATE>=时间,SUM(HSL,BARSLAST(DATE<=时间))>=1200,DRAWNULL);
DRAWTEXT(CROSS(换手1次,0.99),0.95,'换手1次'),COLORYELLOW;
DRAWTEXT(CROSS(换手2次,0.99),0.95,'换手2次'),COLORGREEN;
DRAWTEXT(CROSS(换手3次,0.99),0.95,'换手3次'),COLORWHITE;
DRAWTEXT(CROSS(换手4次,0.99),0.95,'换手4次'),COLORYELLOW;
DRAWTEXT(CROSS(换手5次,0.99),0.95,'换手5次'),COLORGREEN;
DRAWTEXT(CROSS(换手6次,0.99),0.95,'换手6次'),COLORWHITE;
DRAWTEXT(CROSS(换手7次,0.99),0.95,'换手7次'),COLORYELLOW;
DRAWTEXT(CROSS(换手8次,0.99),0.95,'换手8次'),COLORGREEN;
DRAWTEXT(CROSS(换手9次,0.99),0.95,'换手9次'),COLORWHITE;
DRAWTEXT(CROSS(换手10次,0.99),0.95,'换手10次'),COLORYELLOW;
DRAWTEXT(CROSS(换手11次,0.99),0.95,'换手11次'),COLORGREEN;
DRAWTEXT(CROSS(换手12次,0.99),0.95,'换手12次'),COLORWHITE;

通达信真正完全换手指标公式

 

相关文章