在线检测未来函数

通达信粘和离散量指标公式

来源:Internet,编辑:股旁网,2013-12-17

MA5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
离散量30:100*(MA5-(MA15+MA30)/2)/MA30,COLORYELLOW,LINETHICK1;
离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60,COLORCYAN;
粘合K:-2*(离散量30-离散量60),COLORRED,LINETHICK2;
粘合D:=EMA(粘合K,3),COLORYELLOW;
主升:BARSLAST(CROSS(粘合K,粘合D))*(粘合K>粘合D),NODRAW,COLORGREEN;
粘合:=ABS(粘合K)+ABS(离散量60),COLORGREEN;
{离差:当此数>0时,表示"离散量30"在"粘合K"的下方,但只有在"离散量30"上升时才有数}
离差:(粘合K-离散量30)*(离散量30>REF(离散量30,1)),NODRAW;
{关注1:粘合K在0轴附近,同时粘合K与离散量30都处于上升趋势时}
CC:=粘合K-离散量30;
GZ1:=(ABS(粘合-粘合K)<3 AND 粘合K>粘合D) OR (粘合K>-0.5 AND 粘合K<1 AND 粘合K>粘合D) OR (CC>0 AND CC<2 AND 离散量30>REF(离散量30,1));
STICKLINE(GZ1,0,-1,0.8,1),COLORYELLOW;
关注1:IF(GZ1,1,0),COLORYELLOW,NODRAW;
{关注2:包含关注1=1,同时处于上升趋势时}
VAR1:=IF(GZ1=1 AND 粘合K>REF(粘合K,1),1/ABS(粘合-粘合K),0);
GZ2:=IF(VAR1>10,10,IF(VAR1<0.5,0,IF(VAR1<1,1,VAR1)));
STICKLINE(GZ2>0,0,-GZ2,2,0),COLORMAGENTA;
关注2:IF(GZ2>0,1,0),COLORMAGENTA,NODRAW;
{老鸭嘴:有只在粘合K处于上升趋势时,使用此指标一定要注意"粘合K"的趋势}
VAR3:=REF(离散量30,3)>=REF(离散量30,1) AND REF(离散量30,1)<=离散量30 AND (离散量30-粘合K<2) AND 主升>0;
STICKLINE(VAR3,粘合K+1,粘合K-1,1,0),COLORGREEN;
鸭嘴:IF(VAR3,1,0),COLORGREEN,NODRAW;
{三金点:当关注1、关注2、老鸭嘴同时为1时};
三金点:关注1+关注2+鸭嘴,NODRAW;
{判断超跌反弹}
VAR4:=IF(离散量30<-5 AND REF(离散量30,2)>REF(离散量30,1) AND 离散量30>REF(离散量30,1),1,0);
STICKLINE(VAR4,离散量30+2,离散量30,1,0),COLORYELLOW;
反弹:IF(VAR4,1,0),COLORYELLOW,NODRAW;
0,COLORWHITE;

通达信粘和离散量指标公式

 

相关文章