在线检测未来函数

同花顺机构买卖主图指标公式

来源:Internet,编辑:股旁网,2013-12-27

MA5:MA(CLOSE,5),ColorCCCCCC,LINETHICK1;
MA10:MA(CLOSE,10),colorgreen,LINETHICK1;
MA21:MA(CLOSE,21),colorliblue,LINETHICK1;
MA30:MA(CLOSE,30),coloryellow,LINETHICK2;
MA60:MA(CLOSE,60),colorred,LINETHICK3;
MA120:MA(CLOSE,120),Color990099,LINETHICK2;
MA250:MA(CLOSE,250),Color777700,LINETHICK2;
MA500:MA(CLOSE,500),colorblue,LINETHICK2;
买线:=ZIG(3,10);
卖线:=MA(买线,2);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(bu,L*0.99,'←机构进场'),LINETHICK2,COLOR00FFFF;
DRAWTEXT(sel,H*1.0,'←机构清仓'),linethick1,color00FF00;
DRAWTEXT("X09A.T">0,L*0.99,'B'),linethick1,colorFFffff;
DRAWTEXT("X09A.T1">0,L*0.99,'B'),linethick1,color0000ff;
STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),color0000CC;
STICKLINE(买线>=卖线,CLOSE,OPEN,7,0),color0000CC;
STICKLINE(买线<卖线,CLOSE,OPEN,7,0),colorCCCC00;
STICKLINE(买线<卖线,LOW,HIGH,0.1,0),colorCCCC00;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,7,0),color00AAFF;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,7,0),color00DD00;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.99,1);
DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),H,2);
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));
DRAWTEXT((VARC=1),L,'←买'),COLOR0000FF;
DRAWTEXT((VARD=1),H,'←卖'),color00FF00;
V10:=PEAKBARS(3,15,1)<10;
V12:=IF(V10=1,50,0);
头部:= IF(V12=50,100,0);
DRAWTEXT(IF(头部>REF(头部,1),H,0),H*1.02,'←拉升减仓 '),colorwhite,LINETHICK1;
V9:=TROUGHBARS(3,15,1)<10;
V11:=IF(V9=1,50,0);
DRAWTEXT(IF( IF(V11=50,50,0)>REF(IF(V11=50,50,0),1),L,0),L*0.96,'↖抄底 '),colormagenta;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,L*0.99,'←短线资金进'),LINETHICK1,colorlimagenta;
Var12:=(HIGH+LOW+CLOSE)/3;
Var13:=(Var12-MA(Var12,14))/(0.015*AVEDEV(Var12,14));
Var14:=(Var12-MA(Var12,70))/(0.015*AVEDEV(Var12,70));
Var15:=IF(Var13>=150 AND Var13<200 AND Var14>=150 AND Var14<200,10,0);
Var16:=IF(Var13<=-150 AND Var13>-200 AND Var14<=-150 AND Var14>-200,-10,Var15);
Var17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var18:=100-ABS(Var17);
Var19:=IF(Var18<90,Var18,100);
Var1A:=IF(VarE>0,VarE,0);
Var1B:=IF(Var14>=200 AND Var13>=150,15,IF(Var14<=-200 AND Var13<=-150,-15,Var16))+60;
Var1C:=Var1A>48 AND Var1B>60 AND Var19<100;
DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,H*1,'←短线资金出'),linethick1,colorliblue;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
DRAWTEXT(VAR20 AND COUNT(VAR20,1)=1,H*0.99,'↖基金建仓!') , colormagenta;
DRAWTEXT(VAR24 AND COUNT(VAR24,1)=1,L*1.1,'↙基金清仓!') , color00FF00;

同花顺机构买卖主图指标公式

 

相关文章