在线检测未来函数

同花顺组合CCI指标公式

来源:Internet,编辑:股旁网,2013-12-30

LC :=REF(CLOSE,1);
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
MMS:=MA(3*RSI2-2*SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100,3);
MMM:=EMA(MMS,5);
AAA:=MMS-MMM;
STICKLINE(AAA>=0,0,AAA*5,2.3,0),colorred;
STICKLINE(AAA<0,0,AAA*5,2.3,0),colorgreen;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),colorred,LINETHICK3;
MA(CCI,5),LINETHICK2;
CYC13:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYS:=(CLOSE-CYC13)/CYC13*2000;
MA(CYS,3);
0;
-100;
100;
F1:=ZIG(C,8);
F3:=IF(F1>=REF(F1,1),0,100);
VARP1:=(CLOSE+LOW+HIGH)/3;
VARP2:=SUM(((VARP1-REF(LOW,1))-(HIGH-VARP1))*VOL/100000/(HIGH-LOW),0);
VARP3:=EMA(VARP2,1);
JCS:=VARP3;
JCM:=MA(VARP3,10);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击流量,3);
资金流量:=LLJX,colorred,LINETHICK2;
XXX:=F3=0 AND(CROSS(资金流量,0) AND CROSS(JCS,JCM));
YYY:=(F3=0 AND CROSS(REF(资金流量,1),0) AND CROSS(JCS,JCM));
ZZZ:=(F3=0 AND CROSS(资金流量,0) AND CROSS(REF(JCS,1),REF(JCM,1)));
DRAWTEXT(XXX OR YYY OR ZZZ,-120,'买入'),coloryellow;
MA05:=MA(C,3),LINETHICK3,COLOR00CCFF;
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
VAR111:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR22:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,-20,'加码'),colorred;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,100,'风险'),colorcyan;

同花顺组合CCI指标公式

 

相关文章