在线检测未来函数

通达信世界版主图指标公式

来源:Internet,编辑:股旁网,2014-01-01

{全盘穿越主}
上涨家数:"SZ399002$ADVANCE"+"SH999999$ADVANCE"-"SZ399108$ADVANCE",COLORRED,NODRAW;{仅限於日线周期}
下跌家数:"SZ399002$DECLINE"+"SH999999$DECLINE"-"SZ399108$DECLINE",COLORGREEN,NODRAW;
涨跌比:上涨家数/(上涨家数+下跌家数)*100,NODRAW;
MA5:MA(C,5),COLORRED,LINETHICK2;
MA10:MA(C,10),COLORLICYAN;
MA20:=MA(C,20)COLORLICYAN;
MA30:MA(C,30),COLORYELLOW,LINETHICK2;
MA60:=MA(C,60),COLORMAGENTA,LINETHICK1;
MA120:=MA(C,120),COLORLIBLUE;
变色线1:IF(MA5<=REF(MA5,1),MA5,DRAWNULL),COLORGREEN,LINETHICK2;
变色线2:IF(MA30<=REF(MA30,1),MA30,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地域:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.36,0,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.40,0,0,CONST(WINNER(C )*100)),COLORYELLOW;
赢利%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;
DRAWTEXT_FIX(赢利%>=95 AND ISLASTBAR,0.45,0,0,'高危'),COLORRED;
DRAWTEXT_FIX(赢利%>=80 AND 赢利%<95 AND ISLASTBAR,0.45,0,0,'风险'),COLORYELLOW;
DRAWTEXT_FIX(赢利%>=50 AND 赢利%<80 AND ISLASTBAR,0.45,0,0,'安详'),COLORGREEN;
DRAWTEXT_FIX(赢利%<50 AND ISLASTBAR,0.45,0,0,'空头'),COLORBLUE;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.04,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.04,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.12,0,'出千观念:')COLORFF88FF;
DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0.00,0.16,0,'愚民主题观念:'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.09,0.16,0,EXTERNSTR(0,4)),COLOR00FFFF;
{涨停标注}
STICKLINE(C/REF(C,1)>1.095,C,O,3,0),COLORYELLOW;
{全盘穿越}{更多指标公式登陆股民学校}
STICKLINE(C>REF(C,1) AND C>O AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,O,C,3,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C>O AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C>O AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,L,C,0,0), COLORRED;
STICKLINE(C>REF(C,1) AND C>O AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,O,C-(C-O)/2,3,0),COLORBLUE ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,O,C-(C-O)/2,3,0), COLORBLUE ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)/3,3,0),COLORYELLOW;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)/3,3,0),COLORYELLOW ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)*2/3,3,0),COLORBLUE;
STICKLINE(C<REF(C,1)AND REF(100*WINNER(C),1)-100*WINNER(C)>=30 ,O,C,3,0),COLORLIBLUE ;
STICKLINE(C<REF(C,1)AND REF(100*WINNER(C),1)-100*WINNER(C)>=30 ,H,O,0,0),COLORLIBLUE;
STICKLINE(C<REF(C,1)AND REF(100*WINNER(C),1)-100*WINNER(C)>=30 ,L,C,0,0),COLORLIBLUE;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,O*0.985,C,2.5,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,L,C,0,0), COLORRED;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
{现价画直线}
现价:DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3),DOTLINE,COLORLIGRAY;

通达信世界版主图指标公式

 

相关文章