在线检测未来函数

通达信一笑之黄金图主图指标公式

来源:Internet,编辑:股旁网,2014-01-03

用法: A灰色的长短条代表综合筹码集中度,长条的长短代表筹码多少,也意味着对应的压力强弱; B蓝色斑点状条形带代表具体的筹码集中度,可以和A配合判断使用; C红绿相间的三条细线带,代表上中下轨。变红代表股价上升,持股;变绿,股价下跌,持币; D叠加在K线图上的红绿柱可以分别视为多空意愿的反应; E剩余的顶底背离等提示,箱底箱顶等等,配合以上ABCD判断使用效果更好。

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(H,O,L,C);
{底顶侦探}
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
SJ:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
SD:=MA(SJ,2);
SK:=MA(SJ,1);
VAR3:=CROSS(SK,SD) AND SK<0;
VAR4:=CROSS(SK,0);
VAR6:=CROSS(SK,SD) AND SK>0;
BY:=VAR3, STICK;
DRAWICON(BY,L*0.96,23);
BE:=VAR4 OR VAR6, STICK;
DRAWICON(BE,L*0.96,25);
VAR7:=CROSS(SD,SK);
MC:=VAR7, STICK;
DRAWICON(MC,H*1.02,17);
{漓江}
VAR13:=(2*CLOSE+HIGH+LOW)/4;
T:=80, POINTDOT;
VAR14:=LLV(LOW,5);
VAR15:=HHV(HIGH,4);
SK1:=EMA((VAR13-VAR14)/(VAR15-VAR14)*100,4);
SD1:=EMA(0.667*REF(SK1,1)+0.333*SK1,2);
{VAR4:=(HHV(HIGH,4)-VAR1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
漓江倒影: SMA(VAR4,4,1), LINESTICK;}
VAR17:=(VAR13-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
VAR18:=SMA(VAR17,2,1);
桂林山水:=SMA(VAR18,2,1), LINESTICK;
{漓江: 12;}
VAR16:=CROSS(SK1,SD1);
GG:=VAR16, STICK;
DRAWICON(GG,L*0.96,1);
W00:=COST(1);
W10:=COST(10);
W20:=COST(20);
W30:=COST(30);
W40:=COST(40);
W50:=COST(50);
W60:=COST(60);
W70:=COST(70);
W80:=COST(80);
W90:=COST(90);
W100:=COST(99);
W5:=COST(5);
W15:=COST(15);
W25:=COST(25);
W35:=COST(35);
W45:=COST(45);
W55:=COST(55);
W65:=COST(65);
W75:=COST(75);
W85:=COST(85);
W95:=COST(95);
C5:=W5-W00;
C10:=W10-W5;
C15:=W15-W10;
C20:=W20-W15;
C25:=W25-W20;
C30:=W30-W25;
C35:=W35-W30;
C40:=W40-W35;
C45:=W45-W40;
C50:=W50-W45;
C55:=W55-W50;
C60:=W60-W55;
C65:=W65-W60;
C70:=W70-W65;
C75:=W75-W70;
C80:=W80-W75;
C85:=W85-W80;
C90:=W90-W85;
C95:=W95-W90;
C100:=W100-W95;
ZX:=MIN(C5,MIN(C10,MIN(C15,MIN(C20,MIN(C25,MIN(C30,MIN(C35,MIN(C40,MIN(C45,MIN(C50,MIN(C55,MIN(C60,MIN(C65,MIN(C70,MIN(C75,MIN(C80,MIN(C85,MIN(C90,MIN(C95,C100)))))))))))))))))));
STICKLINE(ZX=C5,W00,W5,5,0),COLORFF8800;
STICKLINE(ZX=C10,W10,W5,5,0),COLORFF8800;
STICKLINE(ZX=C15,W15,W10,5,0),COLORFF8800;
STICKLINE(ZX=C20,W20,W15,5,0),COLORFF8800;
STICKLINE(ZX=C25,W25,W20,5,0),COLORFF8800;
STICKLINE(ZX=C30,W30,W25,5,0),COLORFF8800;
STICKLINE(ZX=C35,W35,W30,5,0),COLORFF8800;
STICKLINE(ZX=C40,W40,W35,5,0),COLORFF8800;
STICKLINE(ZX=C45,W45,W40,5,0),COLORFF8800;
STICKLINE(ZX=C50,W50,W45,5,0),COLORFF8800;
STICKLINE(ZX=C55,W55,W50,5,0),COLORFF8800;
STICKLINE(ZX=C60,W60,W55,5,0),COLORFF8800;
STICKLINE(ZX=C65,W65,W60,5,0),COLORFF8800;
STICKLINE(ZX=C70,W70,W65,5,0),COLORFF8800;
STICKLINE(ZX=C75,W75,W70,5,0),COLORFF8800;
STICKLINE(ZX=C80,W80,W75,5,0),COLORFF8800;
STICKLINE(ZX=C85,W85,W70,5,0),COLORFF8800;
STICKLINE(ZX=C90,W90,W85,5,0),COLORFF8800;
STICKLINE(ZX=C95,W95,W90,5,0),COLORFF8800;
STICKLINE(ZX=C100,W100,W95,5,0),COLORFF8800;
筹宽:=W100-W00;
J90:=W90-W60;
J80:=W80-W50;
J70:=W70-W40;
J60:=W60-W30;
J50:=W50-W20;
J40:=W40-W10;
J30:=W30-W00;
STICKLINE(J90/筹宽<0.08,W90,W60,5,0),COLOR74D9A4;
STICKLINE(J80/筹宽<0.08,W80,W50,5,0),COLOR74D9A4;
STICKLINE(J70/筹宽<0.08,W70,W40,5,0),COLOR74D9A4;
STICKLINE(J60/筹宽<0.08,W60,W30,5,0),COLOR74D9A4;
STICKLINE(J50/筹宽<0.08,W50,W20,5,0),COLOR74D9A4;
STICKLINE(J40/筹宽<0.08,W40,W10,5,0),COLOR74D9A4;
JJ90:=W90-W70;
JJ80:=W80-W60;
JJ70:=W70-W50;
JJ60:=W60-W40;
JJ50:=W50-W30;
JJ40:=W40-W20;
JJ30:=W30-W10;
STICKLINE(JJ90/筹宽<0.05,W90,W70,5,0),COLORFFFF00;
STICKLINE(JJ80/筹宽<0.05,W80,W60,5,0),COLORFFFF00;
STICKLINE(JJ70/筹宽<0.05,W70,W50,5,0),COLORFFFF00;
STICKLINE(JJ60/筹宽<0.05,W60,W40,5,0),COLORFFFF00;
STICKLINE(JJ50/筹宽<0.05,W50,W30,5,0),COLORFFFF00;
STICKLINE(JJ40/筹宽<0.05,W40,W20,5,0),COLORFFFF00;
STICKLINE(JJ30/筹宽<0.05,W30,W10,5,0),COLORFFFF00;
DRAWGBK(OPEN>0,RGB(0,0,0),RGB(0,0,0),0,'01',0);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨:(1+7/100)*DD,COLORGREEN;
下轨:(1-7/100)*DD,COLORGREEN;
中轨:(上轨+下轨)/2,COLORGREEN;
疯狂:(1+14/100)*DD,COLORGRAY,POINTDOT;
抄底:(1-14/100)*DD,COLORGRAY,POINTDOT;
DRAWNUMBER(ISLASTBAR,上轨,上轨),COLOR00FFFF;
DRAWNUMBER(ISLASTBAR,下轨,下轨),COLORFFFF00;
DRAWNUMBER(ISLASTBAR,中轨,中轨),COLOR00FF00;
DRAWNUMBER(ISLASTBAR,疯狂,疯狂),COLORBLUE;
DRAWNUMBER(ISLASTBAR,抄底,抄底),COLORWHITE;
上轨红:IF(上轨>=REF(上轨,1),上轨,DRAWNULL),COLORRED,LINETHICK1;
中轨红:IF(中轨>=REF(中轨,1), 中轨,DRAWNULL),COLORRED, LINETHICK1;
下轨红:IF(下轨>=REF(下轨,1), 下轨,DRAWNULL),COLORRED,LINETHICK1;
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));
阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);
止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));
止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);
TJTS1:=BARSTATUS=2 AND C<200;
TJTS2:=BARSTATUS=2 AND C>200;
箱底: LLV(MA((LOW+HIGH+CLOSE+OPEN)/4,6),58),LINETHICK3,COLOR00AAFF;
箱顶: HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58),LINETHICK3,COLOR00AAFF;
B1:=MA(CLOSE,3);
STICKLINE(B1>REF(B1,1),B1,REF(B1,1),3,0),COLORRED;
STICKLINE(B1<REF(B1,1),B1,REF(B1,1),3,0),COLORGREEN;
拉升线:IF(CURRBARSCOUNT=1 AND REF(C,1)<REF(C,2) AND C>REF(C,1) AND A4>REF(A4,1),CONST(REF(C,1)*1.01),DRAWNULL),COLORYELLOW;
M1:STICKLINE(CURRBARSCOUNT=1 AND C>=REF(C,1),拉升线,拉升线*0.998,20,0),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1 AND 拉升线=CONST(REF(C,1)*1.01),L*0.99,'上穿此线介入'),COLORYELLOW;
DRAWKLINE(H,拉升线,L,C);
{顶底背离}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORRED;
{DRAWICON(CROSS(FF,MA15),(LOW * 0.99),7); }
{顶背离}
RSI1:=((SMA(MAX((CLOSE - (REF(CLOSE,1))),0),3,1) / SMA(ABS((CLOSE - (REF(CLOSE,1)))),3,1))* 100);
DRAWTEXT(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),'顶背离'),COLORGREEN;
{DRAWICON(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),8); };
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)>C AND
REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)
<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")
>0,L-0.02,'MACD底背离'),COLORRED;{MACD底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)>C AND
REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)<"KDJ.K" AND
CROSS("KDJ.K","KDJ.D"),L-0.10,'KDJ底背离'),COLORBLUE;{KDJ底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)>C AND
REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)
<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")
>0,L-0.18,'RSI底背离');{RSI底背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)<C
AND REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)
>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")
>0,H+0.16,'MACD顶背离'),COLORGREEN;{MACD顶背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)<C
AND REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)
>"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'KDJ顶背离');{KDJ顶背离};
{涨跌提示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(涨停,OPEN,CLOSE,1.5,0),COLORYELLOW;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(跌停,OPEN,CLOSE,1.5,0),COLORWHITE;
机构:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/CAPITAL;
累计:=EMA(机构,60)*60,COLORMAGENTA;
均值:=EMA(累计,MIN(10,60)),COLORWHITE;
VAR21:=CROSS(累计,均值);
GD:=VAR21, STICK;
DRAWTEXT(GD,L*0.97, '↖启爆点'),COLORYELLOW;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
STICKLINE(C/REF(C,1)<0.95,C,O,2,0),COLORGREEN;

通达信一笑之黄金图主图指标公式

 

相关文章