在线检测未来函数

通达信筹码五彩涨停K线主图指标公式

来源:Internet,编辑:股旁网,2014-01-07

{筹码成本}
五十成本集中:=(COST(75)-COST(25))/(COST(75)+COST(25))*100;
成本价1:COST(五十成本集中),COLORGREEN;
五十成本集中1:=100-五十成本集中;
成本价2:COST(五十成本集中1),COLORBLUE;
底部:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
底部成本价:COST(底部),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=1 AND 底部成本价,底部成本价,底部成本价),COLORYELLOW;
顶部:=100-底部;
顶部成本价:COST(顶部),COLORGREEN;
DRAWNUMBER(CURRBARSCOUNT=1 AND 顶部成本价,顶部成本价,顶部成本价),COLORWHITE;
均值:=(底部+顶部)/2;
均值成本:COST(均值),COLORLICYAN,LINETHICK3;
DRAWBAND(顶部成本价,RGB(68,0,1),均值成本,RGB(68,0,1));
DRAWBAND(均值成本,RGB(3,43,63),底部成本价,RGB(3,43,63));
DRAWKLINE(H,O,L,C);
DRAWNUMBER(CURRBARSCOUNT=1 AND 均值成本,均值成本,均值成本),COLORLIGREEN;
底部突破1:=REF(成本价1,2)>REF(成本价1,1) AND 成本价1>REF(成本价1,1);
DRAWTEXT(底部突破1 ,L*0.99,'大底'),COLORCYAN;
顶部突破3:=REF(成本价2,2)>REF(成本价2,1) AND 成本价2>REF(成本价2,1);
顶部突破4:=REF(成本价2,2)=REF(成本价2,1) AND 成本价2>REF(成本价2,1);
DRAWTEXT(顶部突破3 OR 顶部突破4 ,L*0.99,'跃'),COLORBROWN;
买点1:=REF(均值成本,2)>REF(均值成本,1) AND 均值成本>REF(均值成本,1);
买点2:=REF(均值成本,2)=REF(均值成本,1) AND 均值成本>REF(均值成本,1);
DRAWTEXT(买点1 OR 买点2 AND C>O,L*0.99,'买'),COLORMAGENTA;
底部突破:=REF(底部成本价,2)>REF(底部成本价,1) AND 底部成本价>REF(底部成本价,1);
DRAWTEXT(底部突破 ,L*0.995,'底'),COLORWHITE;
顶部突破:=REF(顶部成本价,2)>REF(顶部成本价,1) AND 顶部成本价>REF(顶部成本价,1);
顶部突破2:=REF(顶部成本价,2)=REF(顶部成本价,1) AND 顶部成本价>REF(顶部成本价,1);
突破顶部:=CROSS(C,顶部成本价);
突破均值成本:=CROSS(C,均值成本);
{涨幅}
涨幅:=(C-REF(C,1))/REF(C,1)*100>5;
{压力线}
TY:=C;
HD1:=FILTER(BACKSET(FILTER(REF(TY,7)=HHV(TY,2*7+1),7),7+1),7);
LD1:=FILTER(BACKSET(FILTER(REF(TY,3)=LLV(TY,2*7+1),7),7+1),7);
A:=REF(C,BARSLAST(HD1));
B:=REF(C,BARSLAST(LD1));
T1:=BARSLAST(HD1)<BARSLAST(LD1) AND NOT(HD1) ;
T2:=BARSLAST(HD1)>BARSLAST(LD1) AND NOT(LD1);
波浪顶:IF(T1,A,A),COLORFF00FF,DOTLINE;
突破:=CROSS(C,波浪顶);
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:(C-O)/O*100,NODRAW;
V型反转:=L<底部成本价 AND DF2;
V型反转2:=CROSS(C,底部成本价) AND DF2;
V型反转3:=L<底部成本价 AND DF3;
成立:=V型反转 OR V型反转2 OR V型反转3;
STICKLINE(成立,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(成立 ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(成立,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(成立,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(成立,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(成立,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(成立 ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(成立 ,O,C,0,1 ),COLORMAGENTA;
DRAWTEXT(成立,L*0.99,'↖狙击'),COLOR00FFFF;
DF:=(C-REF(C,1))/REF(C,1)*100<-4;
DF4:=(C-O)/O*100<-4;
AA:=BARSLAST(DF);
突破箱体:=CROSS(C,REF(C,AA));
箱顶:DRAWLINE(DF,O,REF(DF,1),REF(O,1),1),COLORMAGENTA DOTLINE;
箱顶1:DRAWLINE(DF4,O,REF(DF4,1),REF(O,1),1),COLORYELLOW DOTLINE;
箱底:=LLV(MIN(L,REF(L,AA)),AA),COLORCYAN,LINETHICK2;
反转:=CROSS(C,箱顶) AND REF(DF,1)=1 ;
反转1:=CROSS(C,箱顶1) AND REF(DF4,1)=1;
白K:突破顶部 AND 涨幅 AND C=H;
STICKLINE(白K,C,O,3.5,0 ),COLORWHITE;
DRAWTEXT(白K,L*0.99,'↖白K'),COLORWHITE;
红K:突破均值成本 AND 涨幅 AND C=H;
STICKLINE(红K,C,O,3.5,0 ),COLORRED;
DRAWTEXT(红K,L*0.99,'↖红K'),COLORRED;
黄K:反转 OR 反转1 AND 涨幅 AND C=H;
STICKLINE(黄K,C,O,3.5,0 ),COLORYELLOW;
DRAWTEXT(黄K,L*0.99,'↖黄K'),COLORYELLOW;
粉K:=顶部突破3 OR 顶部突破4 AND 涨幅 AND C=H;
STICKLINE(粉K,C,O,3.5,0 ),COLORLIRED;
DRAWTEXT(粉K,L*0.99,'↖粉K'),COLORLIRED;
绿K:买点1 OR 买点2 AND 涨幅 AND C=H;
STICKLINE(绿K,C,O,3.5,0 ),COLORGREEN;
DRAWTEXT(绿K,L*0.99,'↖绿K'),COLORGREEN;
A111:=COST(85);
A222:=COST(15);
A333:=A111-A222;
A444:=(A111+A222)/2;
DFMJ:=A333/A444*100<30,LINETHICK0;
B1:=HHV(HIGH,250);
B2:=LLV(LOW,250);
BH3:=B1-B2;
B4:=(A444-B2);
DW:=A444<(BH3*04+B2),LINETHICK0;
DWDF:=DW AND DFMJ;
B5:=C/REF(C,1)>1.04 AND C=H;
CMJZ: DWDF AND B4 AND WINNER(C)>=0.95 AND B5;
DRAWICON(CMJZ,LOW*0.99,27);
DRAWTEXT_FIX(1,0,0.05,0,'1、☆白K:突破顶部 ')COLORWHITE;
DRAWTEXT_FIX(1,0,0.10,0,'2、☆红K:突破均值成本 ')COLORRED;
DRAWTEXT_FIX(1,0,0.15,0,'3、☆黄K:反转 ')COLORYELLOW;
DRAWTEXT_FIX(1,0,0.20,0,'4、☆粉K:=跃 ')COLORLIRED;
DRAWTEXT_FIX(1,0,0.25,0,'5、☆绿K:买 ')COLORGREEN;

通达信筹码五彩涨停K线主图指标公式

 

相关文章