在线检测未来函数

通达信OBV导航犬指标公式

来源:Internet,编辑:股旁网,2014-01-11

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
0,DOTLINE;
VA:=IF(C>REF(C,1),V,-V);
OB:=SUM(IF(C=REF(C,1),0,VA),0);
VRA:=(EMA(C,9)-EMA((REF(C,1)+O)/2,9));
AV:VRA*EMA(OB,18)/100,COLORSTICK;
AM9:EMA(AV,9);
AM18:EMA(AV,18);
AM36:EMA(AV,36);
{逃顶指标}
VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARC),AV,14);
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(84,VAR7),AV,'逃顶'),COLORYELLOW;
{量价背离;指变盘在即!}
DV:=EMA(V,18)-EMA(V,36);
DC:=EMA(C,18)-EMA(C,36);
VC:=DV>REF(DV,1) AND DC<REF(DC,1);
B3:=REF(VC,2)=1 AND REF(VC,1)=1 AND VC;
B4:=REF(VC,3)=1 AND REF(VC,2)=1 AND REF(VC,1)=1 AND VC;
DRAWICON(B3 OR B4,0,40);

通达信OBV导航犬指标公式

 

相关文章