在线检测未来函数

通达信CCI短线顶底指标公式

来源:Internet,编辑:股旁网,2014-01-18

N1:=5;
N2:=10;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=(SMA(RSV,9,1));
KK:=INTPART(SMA(RSV,3,1));
DD:=INTPART(SMA(K,3,1));
A:=(KK-DD)*5;
A1:=REF(A,1);
B:=A1-A,COLOR808080;
B1:=REF(A1-A,1);
B2:=REF(A1-A,2);
CC:=B+B1+B2,COLOR00FFFF;
短强:STICKLINE(A>CC AND A>0 ,A,CC,3,0),COLOR0000D5;
转强:STICKLINE(A>CC AND A<0,A,CC,3,0),COLOR00DFDF;
转弱:STICKLINE(A<=CC AND A>0,A,CC,3,0),COLOR00CA00;
弱势:STICKLINE(A<CC AND A<0,A,CC,3,0),COLORFF0000;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK2;
底部W:-200;
买入:-100,COLORGRAY;
卖出:100;
AASS:0;
底部WW:=CROSS(CCI,-100);
DRAWICON(底部WW,-100,1);
顶部W:=CROSS(150,CCI);
DRAWICON(顶部W,150,2);
VAR1A:=EMA(EMA(EMA(CLOSE,1),3),3),COLOR00FF00;
AAS:=VAR1A-REF(VAR1A,1)+VAR1A,;
TYPS:=(HIGH + LOW + CLOSE)/3;
AD:=REF(C,1);
RSISD:=SMA(MAX(C-AD,0),6,1)/SMA(ABS(C-AD),6,1)*100;
A1D:=C-MA(C,5)/MA(C,5)*100<1;
A2D:=C-MA(C,13)/MA(C,13)*100<-10;
A3D:=C-MA(C,34)/MA(C,34)*100<-15;
A4D:=RSI<18;
A5D:=CCI<-120;
底D:(A1D AND A2D AND A3D AND A4D AND A5D)*100;
RK:SMA(CCI,3,1),LINETHICK0;
RD:SMA(RK,3,1),LINETHICK0;
RJ:3*RK-2*RD,LINETHICK0;
头D:=390+REVERSE(EMA(RJ, 1));
底DD:=-290+REVERSE(EMA(RJ,1)),LINETHICK0;
抛D:IF(RJ>头D,200,300),COLORGREEN;
吸D:IF(RJ<底DD,-200,-300),COLORRED,LINETHICK2;
中线: -200*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)),LINETHICK0;
短线: -200*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10)),COLORFFFF00,LINETHICK0;
逃顶线: -5,COLOR00FF00,LINETHICK0;
抄底线: -250,COLORRED,LINETHICK0;
DRAWTEXT(中线>-3.5,逃顶线+220,'逃'),COLORGREEN;
DRAWTEXT(中线<-196,抄底线-18,'底'),COLORFF00FF;
TYPF := (HIGH + LOW + CLOSE)/3;
JG1:=(TYPF-MA(TYPF,N1))/(0.015*AVEDEV(TYPF,N1));
JG2:=(TYPF-MA(TYPF,N2))/(0.015*AVEDEV(TYPF,N2));
JGA:=EMA(JG1,13 );
JGB:=EMA(JG2,13);
AA:=CROSS(JG2,-200) AND JG1>-100;
DRAWTEXT(CROSS(JGB,JGA)AND JGB>0,260,' $逃顶')LINETHICK2 ,COLOR9999FF;
DRAWTEXT(FILTER(AA,5)=1,-260,' $抄底')LINETHICK2, COLORYELLOW;
STICKLINE(CROSS(JGB,JGA)AND JGB>0,180,210,10,0),COLORGREEN ;
STICKLINE(FILTER(AA,5)=1,-180,-210,10,0),COLORRED;

通达信CCI短线顶底指标公式

 

相关文章