在线检测未来函数

通达信合并两日K线主图指标公式

来源:Internet,编辑:股旁网,2014-01-25

ZF:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,' '),HYBLOCK),' '),GNBLOCK),' '),FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,ZF),COLORYELLOW;
STICKLINE(C>0,H,L,0,1),COLORBLACK;
STICKLINE(C>0,O,C,4,1),COLORBLACK;
N:=2;
RY1:=BARSCOUNT(CLOSE);
RY2:=FRACPART(RY1/N)*N;
PO:=IF(RY2=0,O,REF(O,RY2));
PH:=HHV(H,N);
PL:=LLV(L,N);
PC:=C;
STICKLINE(RY2=N-1 AND PC>PO,PH,PL,0,1),COLORRED;
STICKLINE(RY2=N-1 AND PC=PO,PH,PL,0,1),COLORYELLOW;
STICKLINE(RY2=N-1 AND PC<PO,PH,PL,0,0),COLORLIBLUE;
STICKLINE(RY2=N-1 AND PC>PO,PO,PC,6,1),COLORRED;
STICKLINE(RY2=N-1 AND PC=PO,PO,PC,6,1),COLORYELLOW;
STICKLINE(RY2=N-1 AND PC<PO,PO,PC,6,0),COLORLIBLUE;
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
MA5:MA(CLOSE,60);

通达信合并两日K线主图指标公式

 

相关文章