在线检测未来函数

大智慧只赚不亏主图指标公式

来源:Internet,编辑:股旁网,2014-01-27

DRAWTEXTREL(1,10,'■所属板块:'+BKNAME),COLORGREEN;
DRAWTEXTREL(1,60,'■流通盘 :'+CAPITAL/100+'万股'),COLORYELLOW;
DRAWTEXTREL(1,110,'■流通市值:'+DYNAINFO(57)/100000000+'亿'),COLORYELLOW;
DRAWTEXTREL(1,160,'■每股收益:'+FINANCE2(3)),COLORYELLOW;
DRAWTEXTREL(1,210,'■每股净资:'+FINANCE2(4)),COLORYELLOW;
DRAWTEXTREL(1,260,'■主营收入:'+FINANCE2(27)),COLORYELLOW;
DRAWTEXTREL(1,310,'■净利润 :'+FINANCE2(33)),COLORYELLOW;
DRAWTEXTABS(600,180,'不要太迷恋(B)哥'),COLORRed,linethick3;
DRAWTEXTABS(600,220,'(B)哥只是传说(S)'),COLORGreen,linethick3;
a:="[email=LTFunc4@FORLT2]LTFunc4@FORLT2[/email]";
s1:="[email=LTFunc4@LT_S1]LTFunc4@LT_S1[/email]";
hs:="[email=LTFunc4@LT_HS]LTFunc4@LT_HS[/email]";
ls:="[email=LTFunc4@LT_LS]LTFunc4@LT_LS[/email]";
p1:="[email=LTFunc4@LT_P1]LTFunc4@LT_P1[/email]";
upp:="[email=LTFunc4@LT_UPP]LTFunc4@LT_UPP[/email]";
udd:="[email=LTFunc4@LT_UDD]LTFunc4@LT_UDD[/email]";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'丁丁买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;
drawflagtext(1,fb,bs);
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
zz:=(o+h+l)/3;
hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;
xxb:=CLOSE*VOL;
xxbym:EMA((EMA(xxb,3)/EMA(VOL,3)+EMA(xxb,6)/EMA(VOL,6)+EMA(xxb,12)/EMA(VOL,12)+EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;
爱心:=EMA(CLOSE,13)-EMA(CLOSE,55);
无价:=EMA(爱心,3);
PARTLINE(xxbym,爱心>=无价,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK3;
DRAWTEXTREL(575,120,'今日买点:'+NUMTOSTRN(hjmd,2 )),LINETHICK3,coloryellow;
yc:=(h+l)/2;
ychjx:=(EMA(zz,4))+(yc-ref(zz,3))/4;
DRAWTEXTREL(530,30,'昨测今日买点:'+NUMTOSTRN(ref(ychjx,1),2)),LINETHICK3,colorWhite;
DRAWTEXTREL(575,210,'明日买点:'+NUMTOSTRN(ychjx,2)),LINETHICK3,colorff00ff;

大智慧只赚不亏主图指标公式

 

相关文章