在线检测未来函数

同花顺超赢配合拉升指标公式

来源:Internet,编辑:股旁网,2014-01-30

Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,30);
Var4:=MA(CLOSE,60);
VarB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarC:=INTPART(VarB*100)/100;
VarD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VarE:=EMA(VarD,9);
VarF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Var10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Var11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Var12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Var13:=REF(VarE,1);
Var14:=VarE;
Var15:=Var14-Var13;
Var16:=REF(VarD,1);
Var17:=VarD;
Var18:=Var17-Var16;
Var19:=OPEN;
Var1A:=CLOSE;
倍量上攻: IF(Var19<=Var1 AND Var19<=Var2 AND Var19<=Var3 AND Var1A>=Var1 AND Var1A>=VarC AND
Var15>0 AND Var18>0,0.8,0),LINETHICK3 , Color00FFFF;
STICKLINE(倍量上攻,0,倍量上攻*0.86,2,1),LINETHICK2 ,Color00FFFF;
DRAWICON(倍量上攻>0,倍量上攻,1);
ma1:=EMA(CLOSE,5);
ma2:=EMA(CLOSE,10);
ma3:=EMA(CLOSE,20);
ma4:=EMA(CLOSE,30);
三线粘合:CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018,colorff00ff;
STICKLINE(三线粘合,0,三线粘合*0.96,2,1),colorff00ff;
DRAWICON(三线粘合>0,三线粘合,1);
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=HHV((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,200);
m1:=bias1=bias2 ;
m2:=V>MA(V,5) ;
m3:=REF(bias1,1)<REF(bias2,1) ;
追进:IF(m1 AND m2 AND m3,0.60,0),colorffcccc,linethick2;
STICKLINE(追进,0,追进*0.56,2,1),colorffcccc,linethick2;
DRAWICON(追进>0,追进,1);
C1:=HHV(C,115);
C2:=LLV(C,115);
C3:=C1-C2;
C4:=MA((C-C2)/C3-0.5,14)*20;
hh:=REF(HHV(C,66),2);
BUY1:=CROSS(C,hh) AND (HHV(C,110)/LLV(C,110)-1)*100<45 AND C4<5.666;
SIGN1:=LLV(c4,35)<-8.9 AND CROSS(c4,-7.815) AND c4<-1.2;
抄底:1*FILTER(SIGN1,41),STICK,LINETHICK2,COLOR00EE00;
MA5 := MA(CLOSE,5);
MA10 := MA(CLOSE,10);
MA60 := MA(CLOSE,60);
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,60);
Var4:=BARSLAST(CROSS(Var1,Var3));
Var5:=BARSLAST(CROSS(Var2,Var3));
Var6:=BARSLAST(HIGH=HHV(HIGH,Var5));
Var7:=BARSLAST(CROSS(Var2,Var1));
Var8:=BARSLAST(CROSS(Var1,Var2));
Var9:=Var4>Var5 AND Var5>Var6 AND Var6>Var7 AND Var7>Var8 AND Var8<5;
VarA:=COUNT(CROSS(Var2,Var1),Var5)=1;
老鸭头:Var9 AND VarA AND Var3>REF(Var3,1),COLORFF00FF;
DRAWTEXT(老鸭头 ,0.8 , '老鸭头'),colorred;
nA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
nA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
nA3:=COUNT(V<MA(V,10),10)>6;
蜻蜓点水:nA1 AND nA2 AND nA3,COLOR00FF00,LINETHICK2;
DRAWTEXT(蜻蜓点水 ,0.8 , '蜻蜓点水'),colorred;
线:=MA(C,180)>REF(MA(C,180),2) AND COUNT(CROSS(MA(C,5),MA(C,180)),6)>=1 AND C/MA(C,180)>1.04,colorblue;
穿180线:MA(C,180)>REF(MA(C,180),2) AND COUNT(CROSS(MA(C,5),MA(C,180)),6)>=1 AND C/MA(C,180)>1.04,colorblue;
DRAWTEXT(穿180线,0.8 , '180'),colorblue;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=MA(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=IF(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=MA(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=IF(ff3<ff1,ff1,ff3);
ma13:=MA(C,13);
zdhm:=CROSS(C,dkkj) AND CROSS(C,ma13) AND CROSS(C,xkkj);
zhm:=CROSS(C,ma13) AND CROSS(C,xkkj);
的:zdhm OR zhm,colorgreen;
DRAWTEXT(的,0.5,'的'),colorred;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113,colorred;
A12:=C>MAX(MA111,MAX(MA112,MA113)),colorred;
A13:=V/MA(V,30)>1.2,colorred;
A14:=C/REF(C,1)>1.049,colorred;
芙蓉:A11 AND A12 AND A13 AND A14,colorwhite;
DRAWTEXT(芙蓉,0.3,'出水芙蓉'),colorwhite;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
STICKLINE(A1 AND A2 ,0,3,3,0);colorgreen;
STICKLINE(A1 AND A2 ,0,1,3,0);colorblue;
STICKLINE(A1 AND A2 AND A3,0,5,3,0);coloryellow;
STICKLINE(A1 AND A2 AND A3,0,3,3,0);COLORFF00FF;
STICKLINE(A1 AND A2 AND A3,0,1,3,0);colorblue;
DRAWTEXT(A3=1,4.8,'倍量上攻!'),coloryellow;
追击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG
(3,6),2),colorwhite,LINETHICK1;
DRAWTEXT(追击=1,0.8,'买!'),colorwhite;
退: ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG
(3,10),2),coloryellow,LINETHICK1;
DRAWTEXT(退=1,1.3,'卖!'),colorgreen;
VAR3:=PEAKBARS(2,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);

同花顺超赢配合拉升指标公式

 

相关文章