在线检测未来函数

通达信三顾茅庐主图+选股指标公式

来源:Internet,编辑:股旁网,2014-02-02

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)
+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:=VAR1,COLORWHITE;
中线:=VAR6,COLORYELLOW;
DRAWBAND(短线,RGB(255,255,0),中线,RGB(256,200,0));
CB80:EMA(((COST(99.3)+COST(70.7))/2+COST(85))/2,13);
CB66:EMA(((COST(99)+COST(33))/2+COST(66))/2,13);
CB:EMA((((COST(80.9)+COST(19.1))/2+(COST(61.8)+COST(38.2))/2)/2+COST(50))/2,13),LINETHICK2;
CB6:EMA(((COST(6)+COST(16))/2+COST(11))/2,13),LINETHICK2;
{//(C-CB6)>0是C在CB6上方 <0 在下方}
UPDOWN:=IF((C-CB6)<0,1,0);
MACB80:=MA(CB80,13);
MACB66:=MA(CB66,13);
MACB:=MA(CB,13);
MACB6:=MA(CB6,13);
MA向上:=IF((MACB80>REF(MACB80,5) OR MACB66>REF(MACB66,5) OR MACB>REF(MACB,5)) OR MACB6>REF(MACB6,5),1,0);
主力建仓:IF(C>CB6 AND SUM(UPDOWN,220)>20 AND (C/HHV(C,700)<0.5 OR C/LLV(C,700)<1.7) AND MA向上,SUM(UPDOWN,220),0),COLORRED,LINETHICK0;
IF(主力建仓>0,CB6,DRAWNULL),COLORRED,LINETHICK5;
卧龙式盘建仓:IF(主力建仓>0 AND SUM(主力建仓,400)>88,SUM(主力建仓,400),0),COLOR5ADB9A,LINETHICK0;
IF(卧龙式盘建仓>0,CB6*0.91,DRAWNULL),COLOR5ADB9A,LINETHICK5;
刘备捞月式建仓:IF(主力建仓 AND C/HHV(C,700)<0.35,SUM(UPDOWN,220),0),COLORYELLOW,LINETHICK0;
IF(刘备捞月式建仓>0,CB6*0.95,DRAWNULL),COLORYELLOW,LINETHICK5;
三顾茅庐:IF(主力建仓>0 AND 卧龙式盘建仓>0 AND 刘备捞月式建仓>0,(主力建仓+卧龙式盘建仓+刘备捞月式建仓)/3,0),COLORGREEN,LINETHICK0;
IF(三顾茅庐>0,CB6*1.15,DRAWNULL),COLORF8E71F,LINETHICK3;
STICKLINE(三顾茅庐>0,CB6*0.948,CB6*0.90,2.5,0),COLORF8E71F;

{
选股公式:

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)
+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
{三顾茅庐 DESIGNED BY 老大7777 2014.1.3}
CB80:=EMA(((COST(99.3)+COST(70.7))/2+COST(85))/2,13);
CB66:=EMA(((COST(99)+COST(33))/2+COST(66))/2,13);
CB:=EMA((((COST(80.9)+COST(19.1))/2+(COST(61.8)+COST(38.2))/2)/2+COST(50))/2,13);
CB6:=EMA(((COST(6)+COST(16))/2+COST(11))/2,13);
{//(C-CB6)>0是C在CB6上方 <0 在下方}
UPDOWN:=IF((C-CB6)<0,1,0);
MACB80:=MA(CB80,13);
MACB66:=MA(CB66,13);
MACB:=MA(CB,13);
MACB6:=MA(CB6,13);
MA向上:=IF((MACB80>REF(MACB80,5) OR MACB66>REF(MACB66,5) OR MACB>REF(MACB,5)) OR MACB6>REF(MACB6,5),1,0);
主力建仓:=IF(C>CB6 AND SUM(UPDOWN,220)>20 AND (C/HHV(C,700)<0.5 OR C/LLV(C,700)<1.7) AND MA向上,SUM(UPDOWN,220),0);
卧龙式盘建仓:=IF(主力建仓>0 AND SUM(主力建仓,400)>88,SUM(主力建仓,400),0);
刘备捞月式建仓:=IF(主力建仓 AND C/HHV(C,700)<0.35,SUM(UPDOWN,220),0);
三顾茅庐:=IF(主力建仓>0 AND 卧龙式盘建仓>0 AND 刘备捞月式建仓>0,(主力建仓+卧龙式盘建仓+刘备捞月式建仓)/3,0);
三顾茅庐选股:FILTERX(三顾茅庐>0,5) AND (CROSS(VAR1,VAR6)OR VAR1>VAR6);
}

通达信三顾茅庐主图+选股指标公式

 

相关文章