在线检测未来函数

通达信同步K线主图指标公式

来源:Internet,编辑:股旁网,2014-02-05

DRAWGBK(O>C,RGB(57,35,146),RGB(0,0,0),0,'1',0);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,19))/210,COLORYELLOW;
马线:MA(牛线,6),COLORRED;
DRAWBAND(马线,RGB(240,128,128),牛线,RGB(255,255,0));
ZZ:=(3*C+H+L+O)/6;
YC:=(H+L)/2;
YCHJX:=(EMA(ZZ,4))+(YC-REF(ZZ,3))/4;
HJMD:=EMA(ZZ,4),COLORYELLOW,LINETHICK0;
XXB:=CLOSE*VOL;
XXBYM:=EMA((EMA(XXB,3)/EMA(VOL,3)+EMA(XXB,6)/EMA(VOL,6)+EMA(XXB,12)/EMA(VOL,12)+EMA(XXB,24)/EMA(VOL,24))/4,13),COLORFF00FF,LINETHICK0;
B:=ZIG(3,50/5)*100,COLORWHITE;
G:=MA(B,2),COLORYELLOW;
上线:=B;
下线:=G;
STICKLINE(上线>=下线,L,H,0,0),COLORRED;
STICKLINE(上线>=下线,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(上线>=下线,CLOSE,O,2,0),COLOR000088;
STICKLINE(上线>=下线,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(上线>=下线,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(上线>=下线,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(上线<=下线,H,L,0,0),COLORCYAN;
STICKLINE(上线<=下线,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(上线<=下线,CLOSE,O,2,0),COLOR888800;
STICKLINE(上线<=下线,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(上线<=下线,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(上线<=下线,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
涨幅:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(涨幅>9.98,C-CO/3,O+CO/3,2,0),COLOR335555;
STICKLINE(涨幅>9.98,C-CO/3,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(涨幅>9.98,C-CO/3,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(涨幅>9.98,C-CO/3,O+CO/3,0.5,0),COLOR33EEEE;
V5:=CLOSE/REF(CLOSE,2)>=1.1;
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
V8:=BACKSET(V5,3);
买入:=V7 AND COUNT(V7,3)=1,NODRAW;
买入1:=V8 AND COUNT(V8,3)=1,NODRAW;
DRAWTEXT(买入,(O+C)/2,'★'),COLORLIBLUE;
DRAWTEXT(买入1,(O+C)/2,'★'),COLORLIGREEN;
CW:=H+WINNER(C);
OW:=H+WINNER(O);
HW:=H+WINNER(H);
LW:=H+WINNER(L);
AHC1:=C*VOL;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
第二支撑线:1.06*AHC22,COLORMAGENTA,DOTLINE;
第一支撑线:AHC22*0.94,COLORGREEN,DOTLINE;
STICKLINE(CW<OW,LW,HW,0,0),COLORYELLOW;
STICKLINE(CW<OW,CW,OW,2,0),COLOR335555;
STICKLINE(CW<OW,CW,OW,1.5,0),COLOR33AAAA;
STICKLINE(CW<OW,CW,OW,1,0),COLOR33CCCC;
STICKLINE(CW<OW,CW,OW,0.5,0),COLOR33EEEE;
STICKLINE(CW>OW,LW,HW,0,0),COLORMAGENTA;
STICKLINE(CW>OW,CW,OW,2,0),COLOR550055;
STICKLINE(CW>OW,CW,OW,1.5,0),COLORAA00AA;
STICKLINE(CW>OW,CW,OW,1,0),COLORCC00CC;
STICKLINE(CW>OW,CW,OW,0.5,0),COLOREE00EE;
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
今日最高:=O+B2;
预测低一:O-B2,LINETHICK0;
{预测当天收盘价公式}
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:GGG,COLORFFFFFF,LINETHICK0;
高:=今日最高;
收:=FFF;
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2.002*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
DRAWTEXT_FIX(1,0.01,0.00,0,'★ ================================
================================'),COLORYELLOW;
DRAWTEXT_FIX(1,0.01,0.05,0,'【预测最低价】收盘价:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.20,0.05,0,C),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.05,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.1,0, '预测一:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.07,0.1,0,预测低一),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.11,0.1,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.15,0, '最低价'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.07,0.15,0,LOW),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.11,0.15,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.1,0, '预测二:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.20,0.1,0,预测低二),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.1,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.15,0, '最高价:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.20,0.15,0,HIGH),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.15,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.28,0.1,0, '第一压力位:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.38,0.1,0,压力Ⅰ),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.43,0.1,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.28,0.15,0, '第一支撑位:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.38,0.15,0,支撑Ⅰ),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.43,0.15,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.46,0.1,0, '第二压力位:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.56,0.1,0,压力Ⅱ),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.62,0.1,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.46,0.15,0, '第二支撑位:'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.56,0.15,0,支撑Ⅱ),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.62,0.15,0,' 元'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.20,0, '★ ================================
================================'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.25,0,'【用法】 红K买青K卖。红K中有黄色为涨停。粉黄K筹码K。黄彩带牛,
粉红彩带熊'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.88,0,'★预测今日最高价★'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.2,0.88,0,'★预测今日收盘价★'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.4,0.88,0,'★前一日预测收盘价★'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.6,0.88,0,'★前二日预测收盘价★'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.04,0.95,0,今日最高),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.10,0.95,0,'元'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.24,0.95,0,FFF),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.3,0.95,0,'元'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.44,0.95,0,REF(FFF,1)),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.5,0.95,0,'元'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.64,0.95,0,REF(FFF,2)),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.7,0.95,0,'元'),COLORFFCC99;
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
A7:=(2*C+H+L)/4;
操作:=MA(A7,5),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.95,'↑全仓' ),COLORFF00FF;

通达信同步K线主图指标公式

 

相关文章