在线检测未来函数

通达信会心气泡指标公式

来源:Internet,编辑:股旁网,2014-02-10

说明:黄色数字表示进入底部区,绿色数字表示底部反转区,中间一条洋红色线是决定股价走强的生命线。切记只有会心收盘价站在中间线之上才可介入。

VAR1Z:=REF(MA(C,20),10);
开:=O-VAR1Z,NODRAW;
高:=H-VAR1Z,NODRAW;
低:=L-VAR1Z,NODRAW;
会心收盘价:C-VAR1Z,NODRAW;
MID:=(3*会心收盘价+低+开+高)/6;
红线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)
+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)
+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORLIRED;
绿线:=MA(红线,6),COLORLIGREEN;
X1:=ABS(红线)/0.9,COLORBROWN;
气泡:IF(红线<=0,X1,DRAWNULL),COLORYELLOW,NODRAW;
中线:IF(红线<0,(X1+红线)/2,DRAWNULL),COLORMAGENTA,DOTLINE;
DRAWBAND(绿线,RGB(0,124,124),红线,RGB(155,96,96));
DRAWKLINE(高,开,低,会心收盘价);
ZP:=红线<=0 AND 气泡>REF(气泡,1);
天数:DRAWNUMBER(ZP,气泡,BARSLAST(REF(红线,1)>0 AND 红线<0)),COLORYELLOW;
ZP1:=红线<=0 AND 气泡<REF(气泡,1);
天数1:DRAWNUMBER(ZP1,气泡,BARSLAST(REF(气泡>REF(气泡,1),1) AND 气泡<REF(气泡,1))),COLORGREEN;

通达信会心气泡指标公式

 

相关文章