在线检测未来函数

通达信看图解股指标公式

来源:Internet,编辑:股旁网,2014-02-25

周期:=15;
过滤:=8;
选股:=-26;
抄底:=-40;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,周期))/REF(VAR5,周期)*100;
VAR7:=(VAR5-REF(VAR5,周期))/REF(VAR5,周期)*100;
VAR8:=EMA(VAR6,过滤);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,5,0), ,COLORFF0000 ;
低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,5,0), ,COLOR62B3FF;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,10,0), , COLORRED;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,5,0),COLORFF00FF ,;
谨慎观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,10,0),COLOR00FFFF ,;
果断持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,5,1), , COLORGREEN;
VAR9:=(CLOSE-MA(CLOSE,58))/MA(CLOSE,58)*100;
VARA:=VAR9>1*REF(VAR9,1) AND VAR9<选股 AND VAR9>抄底*1.5;
VARB:=VOL/CAPITAL*100;
VARC:=LLVBARS(LOW,50);
VARD:=SUM(VOL,VARC);
VARE:=HHVBARS(HIGH,50);
VARF:=SUM(VOL,VARE);
VAR10:=(CLOSE-REF(OPEN,VARE))/REF(OPEN,VARE)*100;
VAR11:=VARF/CAPITAL*100;
VAR12:=(CLOSE-REF(OPEN,VARC))/REF(OPEN,VARC)*100;
VAR13:=VARD/CAPITAL*100;
VAR14:=MA(CLOSE,3);
VAR15:=REF(CLOSE,2)*0.865;
VAR16:=REF(CLOSE,13)*0.772;
VAR17:=MIN(VAR15,VAR16);
VAR18:=MA(CLOSE,13);
超跌: IF((CLOSE-VAR17)/CLOSE<0.03 AND VAR10<-35 AND SUM(VARB,5)/5<1.8,1,0)*10, , COLORWHITE;
DRAWTEXT(超跌,超跌,' 抄底 '), ,COLORFF0000 ;
VAR19:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR1A:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
VAR1B:=EMA(VAR1A,9);
VAR1C:=2*(VAR1A-VAR1B);
DRAWTEXT(VAR1A<-50 AND VAR19>7 AND VAR1A<VAR1B,-10,'底'), , COLORWHITE;
DRAWTEXT(VAR1A<-50 AND VAR19>7 AND VAR1A>=VAR1B,5,'追'), , COLORWHITE;
STICKLINE(VAR1A<-50 AND VAR19>7,0,-10,5,0),,COLORFFFF00 ;

通达信看图解股指标公式

 

相关文章