在线检测未来函数

飞狐血泪矿工指标公式

来源:Internet,编辑:股旁网,2014-02-27

VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR7:=EMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-HHV(HIGH,5))*100,4);
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR14:=(VAR11-EMA(VAR11,13))/STD(VAR11,13)*100;
VAR17:=EMA(EMA(VAR14,5),13)+50;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VAR17;
VAR1B:=VAR3+VAR8+VAR18;
VAR1C:=VAR4+VAR9+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR2A:=VAR20/4+50;
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR2B:=EMA(EMA(EMA(VAR2A,5),5),5)*2-50+VAR21;
VAR2C:=(VAR1A+VAR1B+VAR1C)/3;
VAR2D:=EMA(VAR2C,13);
VAR2E:=(VAR2A+VAR2C)/2;
短线:=VAR2E;
中线:=(VAR2B+VAR2D)/2;
PARTLINE(短线>REF(短线,1) AND 短线<0,短线),LINETHICK3,colorFF00FF;
PARTLINE(短线>REF(短线,1) AND 短线>0,短线),LINETHICK3,colorFF;
PARTLINE(中线>REF(中线,1),中线),LINETHICK1,colorFF;
PARTLINE(短线<REF(短线,1),短线),LINETHICK1,colorFF00;
PARTLINE(短线<REF(短线,1) AND 短线>95,短线),LINETHICK2,colorFF00;
DRAWTEXT(短线<REF(短线,1) AND 短线>95 AND 中线>REF(中线,1),短线+15,'安全出井'),colorFF;
DRAWTEXT(短线<REF(短线,1) AND 短线>30 AND 短线<100 AND 中线>REF(中线,1),短线+15,'逃难'),colorFF;
PARTLINE(短线<REF(短线,1) AND 短线>中线 AND 短线<88,短线),colorFF00FF;
PARTLINE(中线<REF(中线,1),中线),LINETHICK2,colorFF00;
STICKLINE(CROSS(短线,中线),中线,中线+20,6,0),colorFFFF00;
STICKLINE(CROSS(中线,短线),中线,中线-20,8,0),colorFF;
DRAWTEXT(CROSS(短线,中线),中线-10,'加班加点'),colorFFFF00;
DRAWTEXT(CROSS(中线,短线) AND 中线<50,中线,'塌方'),colorFF;
挖掘矿井:STICKLINE(中线-短线>0,中线,短线,3,0),colorFF00FF;
运输金矿:STICKLINE(中线-短线<0,中线,短线,3,0),color28FFFF;
金矿:STICKLINE(中线<0 AND 中线<REF(中线,1),中线,0,10,0),color1AFFFF;
银矿:STICKLINE(中线<50 AND 中线<REF(中线,1) AND 中线>0 AND 短线>REF(短线,1),50,中线,10,0),colorFFFFFF;
开采:STICKLINE(中线<40 AND 中线<REF(中线,1) AND 短线>REF(短线,1),中线,短线,10,0),colorFFFF00;
出井:STICKLINE(中线>80 AND 短线<REF(短线,1) AND 中线>REF(中线,1),中线,短线,10,0),colorFF00;

飞狐血泪矿工指标公式

 

相关文章