在线检测未来函数

通达信会心主图指标公式

来源:Internet,编辑:股旁网,2014-02-27

{筹码图}
DA1:=IF(280>TOTALBARSCOUNT,TOTALBARSCOUNT,280);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{通达信文字指标}
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),
上市天数));
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率)
,市净率),净资收益率),毛利率),净利润率),主营利润率));
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/
FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,股本市值),COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,财务系数),COLORGRAY;
A1:=EMA(C,17);
A2:=SMA(C,17,1);
DRAWBAND(A2,RGB(0,120,120),A1,RGB(250,20,250));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{涨停K线图}
立桩量:=IF(NAMELIKE('S') OR NAMELIKE('*'),(C-REF(C,1))/REF(C,1)*100>4.95,
(C-REF(C,1))/REF(C,1)*100>9.88);
STICKLINE(立桩量,O,C,3.0,0),COLOR0000BB;
STICKLINE(立桩量,O,C,2.7,0),COLOR0000CC;
STICKLINE(立桩量,O,C,2.4,0),COLOR0011CC;
STICKLINE(立桩量,O,C,2.0,0),COLOR1122DD;
STICKLINE(立桩量,O,C,1.7,0),COLOR2233DD;
STICKLINE(立桩量,O,C,1.3,0),COLOR3344EE;
STICKLINE(立桩量,O,C,1,0),COLOR4455EE;
STICKLINE(立桩量,O,C,0.6,0),COLOR5566FF;
STICKLINE(立桩量,O,C,0.3,0),COLOR6677FF;
{跌停K线图}
VAR3K:=IF(NAMELIKE('S') OR NAMELIKE('*'),(C-REF(C,1))/REF(C,1)*100<-4.95,
(C-REF(C,1))/REF(C,1)*100<-9.88);
STICKLINE(VAR3K,C,O,3,0),COLOR009900;
STICKLINE(VAR3K,C,O,2.2,0),COLOR00BB00;
STICKLINE(VAR3K,C,O,1.5,0),COLOR00DD00;
STICKLINE(VAR3K,C,O,0.5,0),COLOR00FF00;
A11:EMA(C,17),NODRAW;
A22:SMA(C,17,1),COLORWHITE,LINETHICK2;
彩带倍数:A11/A22,NODRAW;
一号:MA(C,80),COLORGREEN,LINETHICK3;
IF(一号>=REF(一号,1),一号,DRAWNULL),LINETHICK3,COLORRED;
IF(一号>=REF(一号,1) AND REF(一号,1)<REF(一号,2),一号,DRAWNULL),CIRCLEDOT,COLORRED;
二号:MA(C,189),COLORBLUE,LINETHICK3;
IF(二号>=REF(二号,1),二号,DRAWNULL),LINETHICK3,COLORYELLOW;
IF(二号>=REF(二号,1) AND REF(二号,1)<REF(二号,2),二号,DRAWNULL),CIRCLEDOT,COLORYELLOW;
{会心原创-顶底}
AA1:=(C-REF(C,1))/REF(C,1)*100;
AA2:=(C-O)/C*100;
DRAWTEXT(((AA1>3 AND AA2<-5) OR (AA2<-10 AND AA1>-9))
AND BARSCOUNT(2) AND REF(C,1)>REF(O,1) AND V=HHV(V,30),H+0.3,'←【顶】')
,COLORCYAN;
DRAWTEXT((AA2>12 AND BARSCOUNT(2) AND V=HHV(V,30)) OR (AA2>16 AND V<MA(V,3))
,H+0.3,'←【逃】'),COLORGREEN;
BY1:=((AA1>3 AND AA2<-5) OR (AA2<-10 AND AA1>-9)) AND BARSCOUNT(2) AND REF
(C,1)>REF(O,1) AND V=HHV(V,30);
下突破:REF(C,BARSLAST(BY1)),COLORMAGENTA,CROSSDOT,LINETHICK2;
上突破:REF(O,BARSLAST(BY1)),COLORMAGENTA,CROSSDOT,LINETHICK2;
DRAWICON(CROSS(C,上突破) AND REF(EVERY(C<上突破,30),1),H+0.3,13);
DRAWTEXT(CROSS(C,上突破) AND REF(EVERY(C<上突破,30),1),H+0.5,'突破'),COLORYELLOW;
DRAWTEXT(O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,30) AND C>MA(C,5)
AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,30),L*0.99,'四线合一'),COLORLIGREEN;
DRAWICON(O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,30) AND C>MA(C,5)
AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,30) AND EXIST(CROSS(MA(C,20),MA(C,30)),3),L*0.98,13);
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,5);
VAR3:=HHV(HIGH,5);
VAR4:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,5);
MA1:=MA(VAR4,2);
VAR1Z:=(C+O+L+H)/4;
收:=C-VAR1Z;
XG:=VAR4>50 AND MA1<50 AND O<MA(C,10) AND O<=EMA(C,17) AND C>MA(C,10) AND C>EMA(C,17) AND
EMA(C,17)>SMA(C,17,1) AND SMA(C,17,1)>MA(C,80) AND MA(C,80)>MA(C,189) AND 收>MACD;
STICKLINE(XG,O,C,2.8,0),COLOR335555;
STICKLINE(XG,O,C,2,0),COLOR338888;
STICKLINE(XG,O,C,1.5,0),COLOR33AAAA;
STICKLINE(XG,O,C,1,0),COLOR33CCCC;
STICKLINE(XG,O,C,0,0),COLOR33EEEE;
A10:MA(C,10),LINETHICK2,COLORAA0000;
IF(A10>REF(SMA(A10,3,1),1),A10,DRAWNULL),COLOR0000AA,LINETHICK2;

通达信会心主图指标公式

 

相关文章