在线检测未来函数

飞狐四色KDJ指标公式

来源:Internet,编辑:股旁网,2014-03-09

N1:=17;
N2:=34;
STICKLINE(C>0,40,60,10,0),COLOR999999;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
短K:SMA(RSV,3,1),COLORF580F5,LINETHICK0;
短D:SMA(短K,3,1),COLORCCDD33,LINETHICK0;
RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
中K:SMA(RSV1,5,1),colorred,LINETHICK0;
中D:SMA(中K,10,1),COLOR00FFFF,LINETHICK0;
短:=3*短K-2*短D,colorred,LINETHICK4;
中:=3*中K-2*中D,colorred,LINETHICK4;
趋势线:(短+中)/2,Color3EFFFF,LINETHICK2;
底线:10,colorwhite;
顶线:90,Color33FF33;
BB:=IF(BARSLAST(CROSS(短K,RSV))>=3 AND CROSS(RSV,短K) AND 短K<30,20,0);
STICKLINE(BB,0,50,8,1),Color0000bb;
STICKLINE(BB,0,50,4,1),Color0000dd;
STICKLINE(BB,0,50,2,1),Color0000ff;
AA:=IF(BARSLAST(CROSS(RSV,短K))>=4 AND CROSS(短K,RSV) AND RSV>50,20,0);
STICKLINE(AA,80,100,8,1),ColorD8D8D8;
STICKLINE(AA,80,100,4,1),ColorE8E8E8;
STICKLINE(AA,80,100,2,1),ColorFFFFFF;
STICKLINE(短K>短D,短K,短D,8,1),Color820082;
STICKLINE(短K>短D,短K,短D,6,1),ColorB700B7;
STICKLINE(短K>短D,短K,短D,4,1),ColorF700F7;
STICKLINE(短K>短D,短K,短D,2,1),ColorFF37FF;
STICKLINE(短K<=短D,短K,短D,8,1),ColorBFBF00;
STICKLINE(短K<=短D,短K,短D,6,1),ColorE8E800;
STICKLINE(短K<=短D,短K,短D,4,1),ColorFFFF15;
STICKLINE(短K<=短D,短K,短D,2,1),ColorFFFF46;
STICKLINE(中K>中D,中K,中D,8,0),COLOR000099;
STICKLINE(中K>中D,中K,中D,6,0),COLOR0000dd;
STICKLINE(中K>中D,中K,中D,4,0),COLOR0000cc;
STICKLINE(中K>中D,中K,中D,2,0),COLOR0000ff;
STICKLINE(中K<=中D,中K,中D,8,0),COLOR009FFF;
STICKLINE(中K<=中D,中K,中D,6,0),COLOR00B5FF;
STICKLINE(中K<=中D,中K,中D,4,0),COLOR00E4FF;
STICKLINE(中K<=中D,中K,中D,2,0),COLOR00FFFF;

飞狐四色KDJ指标公式

 

相关文章