在线检测未来函数

通达信修改冠军一号主图指标公式

来源:Internet,编辑:股旁网,2014-03-09

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
GO0B:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0B:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;
STICKLINE(1=1,GO0B,DO0B,5,0),COLOR222222;
D90H:=EMA(HH,90),COLORRED,LINETHICK1;
D90L:=EMA(LL,90),COLORRED,LINETHICK1;
D90:(D90H+D90L)/2;
DGH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;DDL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90C:=D90H-D90L;
G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))+XMA(XMA(H,25),25);
D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25));
GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;
DTD:=(D0+G0)/2>=(D90H+D90L)/2;
KTD:=(D0+G0)/2<(D90H+D90L)/2;
YM:EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),COLORWHITE,LINETHICK1;
YM1:EMA(YM,5),COLORWHITE,LINETHICK1;
YM2:EMA(YM1,5),COLORWHITE,LINETHICK1;
YM3:EMA(YM2,5),COLORWHITE,LINETHICK1;
D1:EMA(D90,10),COLORWHITE,LINETHICK1;
D2:EMA(D1,10),COLORWHITE,LINETHICK1;
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),L*0.99,'买'),COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),H*1.01,'卖'),COLORGREEN;
IF(DTD=1,YM,DRAWNULL),LINETHICK1,COLORRED;
IF(DTD=1,YM1,DRAWNULL),LINETHICK1,COLORRED;
IF(DTD=1,YM2,DRAWNULL),LINETHICK1,COLORRED;
IF(DTD=1,YM3,DRAWNULL),LINETHICK1,COLORRED;
IF(KTD=1,YM,DRAWNULL),LINETHICK1,COLORGREEN;
IF(KTD=1,YM1,DRAWNULL),LINETHICK1,COLORGREEN;
IF(KTD=1,YM2,DRAWNULL),LINETHICK1,COLORGREEN;
IF(KTD=1,YM3,DRAWNULL),LINETHICK1,COLORGREEN;
IF(D90>D1,D90,DRAWNULL),LINETHICK1,COLORRED;
IF(D90>D1,D1,DRAWNULL),LINETHICK1,COLORRED;
IF(D90>D1,D2,DRAWNULL),LINETHICK1,COLORRED;
DX:DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),HHV(HIGH,4),1),POINTDOT,COLORMAGENTA;
KX:DRAWLINE(LOW<=LLV(LOW,20),LOW,HIGH>=HHV(HIGH,20),LLV(LOW,4),1),POINTDOT,COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,G0,'卖'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,D0,'买'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,GO0,'顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,DO0,'底'),COLORMAGENTA;
CC:=((HIGH+LOW+CLOSE)/3-EMA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));
STICKLINE(CC>=0,LOW,HIGH,0.0,0),COLORRED;
STICKLINE(CC>=0,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(CC<0,LOW,HIGH,0.0,0),COLORGREEN;
STICKLINE(CC<0,CLOSE,OPEN,3,1),COLORGREEN;
大单动向:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7);
涨跌动因:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);
大单差分:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);
DDZ1:=大单差分*7;
DDZ2:=大单差分*3;
主力活跃度:=LARGEINTRDVOL-LARGEOUTTRDVOL;
主力净流入:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*AMO/V/10000;
买入力度:=LARGEINTRDVOL*100/VOL;
卖出力度:=LARGEOUTTRDVOL*100/VOL;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
资金流向:=(超B+大B+中B+小B)-(超S+大S+中S+小S);
主力:=(超B+大B+中B)-(超S+大S+中S);
机构:=(超B+大B)-(超S+大S);
私募:=(大B+中B)-(大S+中S);
散户:=(中B+小B)-(中S+小S);
大单:=(大B)-(大S);
中单:=(中B)-(中S);
资金启动:=大单>0 AND 私募>0 AND 机构>0 AND 主力>0 AND 资金流向>0 AND 大单动向>0 AND 涨跌动因>0 AND DDZ1>0 AND DDZ2>0 AND 主力活跃度>0 AND 主力净流入>0 AND 买入力度>卖出力度;
STICKLINE(资金启动=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(资金启动=1,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(L<D0 AND DTD=1 AND YM>YM1,L,D0,3,0),COLORWHITE;
T:=80;TT:=3;N1:=0;
高1:=REF(HHV(H,T),TT);
低1:=REF(LLV(L,T),TT);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
高:REFDATE(高1,DATE),COLORRED;
一:REFDATE(H1,DATE),COLORLIGRAY;
二:REFDATE(H2,DATE),COLORYELLOW;
三:REFDATE(H3,DATE),COLORWHITE;
四:REFDATE(H4,DATE),COLORYELLOW;
五:REFDATE(H5,DATE),COLORLIGRAY;
低:REFDATE(低1,DATE),COLORGREEN;
TT3:=(CURRBARSCOUNT=5);
TT4:=(CURRBARSCOUNT=5+3);
DRAWNUMBER(TT3 AND 高,高,高),COLORYELLOW;
DRAWTEXT(TT4 AND 高,高*1.01,'顶'),COLORMAGENTA;
DRAWNUMBER(TT3 AND 一,一,一),COLORYELLOW;
DRAWTEXT(TT4 AND 一,一*1.01,''),COLORRED;
DRAWNUMBER(TT3 AND 二,二,二),COLORYELLOW;
DRAWTEXT(TT4 AND 二,二*1.01,''),COLORRED;
DRAWNUMBER(TT3 AND 三,三,三),COLORYELLOW;
DRAWTEXT(TT4 AND 三,三*1.01,'中'),COLORMAGENTA;
DRAWNUMBER(TT3 AND 四,四,四),COLORYELLOW;
DRAWTEXT(TT4 AND 四,四*1.01,''),COLORRED;
DRAWNUMBER(TT3 AND 五,五,五),COLORYELLOW;
DRAWTEXT(TT4 AND 五,五*1.01,''),COLORRED;
DRAWNUMBER(TT3 AND 低,低,低),COLORYELLOW;
DRAWTEXT(TT4 AND 低,低*1.01,'底'),COLORMAGENTA;

通达信修改冠军一号主图指标公式

 

相关文章