在线检测未来函数

通达信叠伏系统指标公式

来源:Internet,编辑:股旁网,2014-03-07

CC:=FORCAST(C,3);
OO:=FORCAST(O,3);
HH:=FORCAST(H,3);
LL:=FORCAST(L,3);
SHORT:=21;
LONG:=34;
M:=13;
{1.MACD}
DIFFFF:=EMA(CC,SHORT) - EMA(CC,LONG);
DEAAA:=EMA(DIFFFF,M);
MKCD:=WMA((DIFFFF-DEAAA),3)*400,COLOR00FF00,LINETHICK2;
{IF(MKCD>REF(MKCD,1),MKCD,DRAWNULL),COLOR0000FF,LINETHICK2;}
{2.MACD的BTX}
{差可能是正,是负-----相当与DIFF}
DC:=WMA(CC,SHORT/2)-WMA(CC,LONG/2); {收盘价的DIFF}
DK:=WMA(OO,SHORT/2)-WMA(OO,LONG/2); {开盘价的DIFF}
DH:=(WMA(HH,SHORT/2)-WMA(HH,LONG/2))*1.8; {最高价的DIFF}
DL:=(WMA(LL,SHORT/2)-WMA(LL,LONG/2))*1.8; {最低价的DIFF}
VARVA1:=DC>REF(DC,1) AND DC>REF(DC,2);
VARVA2:=REF(VARVA1,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VARVA3:=REF(VARVA2,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARVA4:=REF(VARVA3,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VARVA5:=REF(VARVA4,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARVA6:=REF(VARVA5,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VARVA7:=REF(VARVA6,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARVA8:=REF(VARVA7,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VARVA9:=REF(VARVA8,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARA:=REF(VARVA9,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VARB:=REF(VARA,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARC:=REF(VARB,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
STICKLINE(VARVA1 OR VARVA2 OR VARVA3 OR VARVA4 OR VARVA5 OR VARVA6 OR VARVA7 OR VARVA8 OR VARVA9 OR VARA OR VARB OR VARC,DC,REF(DC,1),3,0),COLOR0F33AA;
STICKLINE(VARVA1 OR VARVA2 OR VARVA3 OR VARVA4 OR VARVA5 OR VARVA6 OR VARVA7 OR VARVA8 OR VARVA9 OR VARA OR VARB OR VARC,DC,REF(DC,1),2,0),COLOR0F66CC;
STICKLINE(VARVA1 OR VARVA2 OR VARVA3 OR VARVA4 OR VARVA5 OR VARVA6 OR VARVA7 OR VARVA8 OR VARVA9 OR VARA OR VARB OR VARC,DC,REF(DC,1),1,0),COLOR0F99DD;
VARD:=DC<REF(DC,1) AND DC<REF(DC,2);
VARE:=REF(VARD,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VARF:=REF(VARE,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VAR10:=REF(VARF,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VAR11:=REF(VAR10,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VAR12:=REF(VAR11,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VAR13:=REF(VAR12,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VAR14:=REF(VAR13,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VAR15:=REF(VAR14,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VAR16:=REF(VAR15,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
VAR17:=REF(VAR16,1) AND DC<=REF(DC,1) AND DC>=REF(DC,2);
VAR18:=REF(VAR17,1) AND DC>=REF(DC,1) AND DC<=REF(DC,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,DC,REF(DC,1),3,0),COLORFF3322;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,DC,REF(DC,1),2,0),COLORFF6622;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,DC,REF(DC,1),1,0),COLORFF9922;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VARVA1;
STICKLINE(VAR19,REF(DC,1),REF(DH,2),0.1,0),COLOR0000FF;
STICKLINE(VAR19,REF(DC,1),REF(DC,2),4,0),COLOR0000FF;
VAR1A:=REF(VARVA1 OR VARVA2 OR VARVA3 OR VARVA4 OR VARVA5 OR VARVA6 OR VARVA7 OR VARVA8 OR VARVA9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(DC,1),REF(DL,2),0.1,0),COLOR00FF00;
STICKLINE(VAR1A,REF(DC,1),REF(DC,2),4,0),COLOR00FF00;
AA:=DC>REF(DC,1) AND REF(DC,1)>REF(DC,2) AND REF(DC,1)<REF(DC,3) AND IF(REF(DC,3)<REF(DC,4),1,IF(REF(DC,4)<REF(DC,5),REF(DC,1)<REF(DC,4) OR (REF(DC,2)<REF(DC,4) AND REF(DC,3)>=REF(DC,5)),IF(REF(DC,5)<REF(DC,6),1,REF(DC,6)<REF(DC,7))));
BBB:=DC<REF(DC,1) AND REF(DC,1)<REF(DC,2) AND REF(DC,1)>REF(DC,3) AND IF(REF(DC,3)>REF(DC,4),1,IF(REF(DC,4)>REF(DC,5),REF(DC,1)>REF(DC,4) OR (REF(DC,2)>REF(DC,4) AND REF(DC,3)<=REF(DC,5)),IF(REF(DC,5)>REF(DC,6),1,REF(DC,6)>REF(DC,7))));
DRAWTEXT(AA AND DC>REF(DK,1),DL*0.92,'转红'),COLOR0044FF;
DRAWTEXT(BBB AND DC<REF(DC,1),DH*1.08,'转绿'),COLOR00FF00;
DFC:=C-REF(C,1);{收盘价前差值,K线微分}
WJXS:=(120-60)/10;{微积分系数,可由中值定理导出,为兼顾后面引用及统一标尺,前移至此}
JGL_JF:=WJXS*EMA(DFC,60);{内层积分,隐含积分限[1--SHORT],结果:WJXS*EMA(EMA(CC,SHORT)-REF(EMA(CC,SHORT),1),LONG)}
DIF_JIP:=EMA(JGL_JF,120);{外层积分,重积分,隐含积分限[1--LONG],结果:EMA(CC,SHORT)-EMA(CC,LONG)}
DEA_GEM:=EMA(DIF_JIP,20);{平滑,压制高频}
MACD_LING:=400*(DIF_JIP-DEA_GEM),COLOR1133FF,COLORSTICK;{差值滤波然后作2倍放大,显示红、青色针状线柱}
K_DF_J:=SMA(JGL_JF,13,1),COLORFEDCBA;{平滑,压制超短线杂波}
D_DF_G:=SMA(K_DF_J,13,1),COLOR13F8F9;{再平滑,圆滑超短线造成的扰动}
J_DF_L:=2.5*K_DF_J-1.5*D_DF_G,COLORF813F9;{有源差值滤波,取得中高频短线信号}
RF:=REF(J_DF_L,1);
DJ:=ABS(J_DF_L-RF);
MM:=(HHV(DJ,120)+LLV(DJ,120))/2;
STICKLINE(J_DF_L>RF,J_DF_L,RF,2.3,0),COLORYELLOW;
STICKLINE(J_DF_L>0 AND J_DF_L>RF,J_DF_L,RF,1.0,0),COLORRED;
STICKLINE(J_DF_L<0 AND J_DF_L>RF,J_DF_L,RF,1.0,0),COLORMAGENTA;
STICKLINE( J_DF_L<RF,J_DF_L,RF,2.3,0),COLOR338833;
STICKLINE(J_DF_L>0 AND J_DF_L<RF,J_DF_L,RF,1.0,0),COLORLIRED;
STICKLINE(J_DF_L<0 AND J_DF_L<RF,J_DF_L,RF,1.0,0),COLORWHITE;
STICKLINE(J_DF_L<RF AND DJ<0.2*MM,J_DF_L+0.15*MM,RF-0.15*MM,0.1,0),COLOR33AA33;
STICKLINE(J_DF_L>=RF AND DJ<0.2*MM,RF-0.1*MM,J_DF_L+0.1*MM,0.1,0),COLOR13AADD;

通达信叠伏系统指标公式

 

相关文章