在线检测未来函数

飞狐锦绣江山指标公式

来源:Internet,编辑:股旁网,2014-03-13

DRAWGBK(1,colorrgb(30,80,255),colorrgb(200,250,255),1);
主筹:EMA(WINNER(C)*70,3),LINETHICK1,Color00A8A8;
散筹:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),LINETHICK1,colorgreen;
筹码锁定:散筹-主筹,COLORFFBB00;
涨:=CROSS(主筹,筹码锁定);
强:=CROSS(主筹,散筹);
FILLRGN(主筹>散筹,主筹,散筹),Color00D200;
FILLRGN(筹码锁定>0,筹码锁定,散筹),color009900;
FILLRGN(筹码锁定<=0,0,散筹)color009900;
FILLRGN(筹码锁定>0,0,筹码锁定){,COLORFFBB00},COLORFFBB00;
FILLRGN(筹码锁定<0,0,筹码锁定),Color808000;
FILLRGN(筹码锁定<-50,-50,筹码锁定),Color808080;
{FILLRGN(主筹>60,60,主筹),Colorwhite;}
VAR1:=IF(C>=O,H,0);
VAR2:=IF(C<=O,REF(H,1),VAR1);
VAR3:=IF(C>=O,V,0);
VAR4:=IF(C<=O,REF(V,1),VAR3);
VAR5:=COUNT(VAR2>REF(VAR2,1) AND VAR4<REF(VAR4,1),3)>=2 AND C>O;
量价背离:VAR5*10,STICK,COLORf5cceb,LINETHICK2;
抄底:=FILTER((CROSS(5,主筹) and 散筹<20 )*60,10 );
aa:= ref(主筹,30)>40 or ref(主筹,20)>40;
aa1:=cross(主筹,散筹);
bb:=CROSS(28,主筹) and 散筹>40 and aa=1 and LLV(l ,60 )>LLV(l ,250 );
cc1:=cross(主筹,筹码锁定);
底部:EMA(IF(L<= LLV(l,99),SMA(ABS(L-REF(L,1)),99,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3),COLORYELLOW;
FILLRGN(底部>0,0,底部),COLORyellow;
主筹,LINETHICK2,Color00A8A8;
N:=54;
VAR2N:=1;
V1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);
V2:=(2 * ABS(V1));
V3:=(((100 - 100) - (3 * SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1)));
V4:=(((100 - 100) - (3 * SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1)));
V5:=(((HIGH + LOW) + CLOSE) / 3);
V6:=(((V5 - MA(V5,10)) / 0.015) * AVEDEV(V5,10));
V7:=(((V5 - MA(V5,30)) / 0.015) * AVEDEV(V5,30));
V8:=IF(((((V6 >= 150) AND (V6 < 200)) AND (V7 >= 150)) AND (V7 < 200)),10,0);
V9:=(IF(((((V6 <= (0 - 150)) AND (V6 > (0 - 200))) AND (V7 <= (0 - 150))) AND (V7 > (0 - 200))),(0 - 10),V8) * VAR2N);
VA:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
VB:=(100 - ABS(VA));
VC:=((3 * SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VD:=((3 * SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VE:=(REF(LOW,1) * 0.9);
VF:=(LOW * 0.9);
V10:=(((VF * VOL) + (VE * (CAPITAL - VOL))) / CAPITAL);
V11:=EMA(V10,30);
V12:=(V11 - CLOSE);
V13:=REF(CLOSE,1);
V14:=((SMA(MAX((CLOSE - V13),0),7,1) / SMA(ABS((CLOSE - V13)),7,1)) * 100);
V15:=((SMA(MAX((CLOSE - V13),0),13,1) / SMA(ABS((CLOSE - V13)),13,1)) * 100);
V16:=BARSCOUNT(CLOSE);
V17:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100);
V18:=(((((0 - 100) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 50) * 2);
V19:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
V1A:=((SMA(V19,4,1) - 50) * 2);
V1B:=SMA(V1A,3,1);
V1C:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
V1D:=SMA(V1C,4,1);
V1E:=SMA(V1D,3,1);
V1F:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
V20:=(IF((((((((((V17 <= 25) AND (V18 < (0 - 95))) AND (V1F > 20)) AND (V1B < (0 - 30))) AND (V1E < 30)) AND (V12 >= (0 - 0.25))) AND (V14 < 22)) AND (V15 < 28)) AND (V16 > 50)),80,0) * VAR2N);
空方:=(0 - (IF((V1 < 0),V2,0) * VAR2N));
底线:=(SMA(SMA((((CLOSE - LLV(LOW,N)) / (HHV(HIGH,N) - LLV(LOW,N))) * 100),7,1),5,1) * VAR2N);
C0:=(((HIGH + LOW) + CLOSE) / 3);
A1:=HHV(C0,14);
A2:=LLV(C0,14);
A3:=(A1 - A2);
A4:=(EMA(((C0 - A2) / A3),2) * 100);
B1:=HHV(C0,30);
B2:=LLV(C0,30);
B3:=(B1 - B2);
B4:=(EMA(((C0 - B2) / B3),2) * 100);
C1:=HHV(C0,55);
C2:=LLV(C0,55);
C3:=(C1 - C2);
C4:=(EMA(((C0 - C2) / C3),2) * 100);
A10:=(A4 - 50);
A20:=(B4 - 50);
A30:=(C4 - 50);
DRAWICON(CROSS(A1,0),0,4);
RSV2:=(((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30))) * 100);
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=((3 * K2) - (2 * D2));
散步:=(((SMA((((CLOSE - LLV(LOW,N)) / (HHV(HIGH,N) - LLV(LOW,N))) * 100),7,1) * VAR2N) * 16.18) - ((底线 * 10.9) * VAR2N));
筹线:=(ABS(((CLOSE - LLV(LOW,265)) / LLV(LOW,265))) * 100);
码头:(IF(((散步 < 底线) AND (空方 < (0 - 35))),(0 - 5),0) * VAR2N),LINETHICK1,COLORFFBB00;
V1:=EMA(CLOSE,60)-EMA(CLOSE,300);
V2:=EMA(V1,300);
V3:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
V4:=SMA(V3,2,1);
V5:=SMA(V4,2,1);
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
V10:=PEAKBARS(3,15,1)<10;
V12:=IF(V10=1,50,0);
头部:= IF(V12=50,100,0);
卖:=IF(头部>REF(头部,1),30,0);
V9:=TROUGHBARS(3,15,1)<10;
V11:=IF(V9=1,50,0);
大底:= IF(V11=50,50,0);
买:=IF( 大底>REF(大底,1),30,0);
买进:=if(ref(买=30,1) and 买=0,1,0);
STICKLINE(买进,0,10,5,0),COLORyellow;
卖出:=IF(ref(卖=30,1) and 卖=0,1,0);
STICKLINE(卖出,0,10,5,0),COLORgreen;
drawtext(卖出 and date>1071231 and date<1080430,30,'^~\~ '),colorwhite;
drawtext(卖出 and date>1080531,50,'~\~ '),colorwhite;
drawtext(卖出 and date>1080931,43,'~\~ '),colorwhite;
drawtext(卖出 and date>1081231,36,'~\~ '),colorwhite;

飞狐锦绣江山指标公式

 

相关文章