在线检测未来函数

飞狐峰谷均线主图指标公式

来源:Internet,编辑:股旁网,2014-03-15

input: N(55,1,100);
AA:=REF(H,N)=HHV(H,2*N+1);
BB:=BACKSET(AA,N+1);//未来涵数 “BACKSET”
CC:=FILTER(BB,N) AND H=HHV(H,N+1);
AA2:=REF(L,N)=LLV(L,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND L=LLV(L,N+1);
AA3:=REF(H,2*N)=HHV(H,4*N+1);
BB3:=BACKSET(AA3,2*N+1);
CC3:=FILTER(BB3,2*N) AND H=HHV(H,2*N+1);
AA4:=REF(L,2*N)=LLV(L,4*N+1);
BB4:=BACKSET(AA4,2*N+1);
CC4:=FILTER(BB4,2*N) AND L=LLV(L,2*N+1);
a1:=BARSLAST(CC);
M1:ma(h,a1+1),PRECISION2,LINETHICK0,COLORYELLOW;
PARTLINE(a1>0,M1),COLORYELLOW;
a11:=ref(a1,a1+1);
M2:ma(h,a11+a1),PRECISION2,LINETHICK0,COLORCYAN;
PARTLINE(a1>0,M2),COLORCYAN;
a2:=BARSLAST(CC2);
M3:ma(l,a2+1),PRECISION2,LINETHICK0,COLORMAGENTA;
PARTLINE(a2>0,M3),PRECISION2,COLORMAGENTA;
a22:=ref(a2,a2+1);
M4:ma(l,a22+a2),PRECISION2,LINETHICK0,COLORWHITE;
PARTLINE(a2>0,M4),COLORWHITE;
a3:=BARSLAST(CC3);
M5:ma(h,a3+1),PRECISION2,LINETHICK0,COLORBLUE;
PARTLINE(a3>0,M5),COLORBLUE;
a4:=BARSLAST(CC4);
M6:ma(l,a4+1),PRECISION2,LINETHICK0,COLORGREEN;
PARTLINE(a4>0,M6),COLORGREEN;

飞狐峰谷均线主图指标公式

 

相关文章