在线检测未来函数

通达信判断低点主图指标公式

来源:Internet,编辑:股旁网,2014-03-19

N:=20,200,50;
TS:=BARSLAST(L=LLV(L,N));
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=CONST(开始天数);
低点:DRAWLINE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),1),COLOR00CC00;
高点:DRAWLINE(L=LLV(L,N),CONST(HHV(H,天数横线)),ISLASTBAR,REF(CONST(HHV(H,天数横线)),
TS),1),COLOR00CCCC;
STICKLINE(开始信号,L,CONST(HHV(H,天数横线)),0,0),COLOR00AA00;
STICKLINE(ISLASTBAR,低点,高点,0,0),COLOR00AA00;
C2:=REF(C,1);
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
差:=(高点-低点)/天数横线;
收盘差:=CONST(C)-低点;
对角差:=高点-低点;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFFFF00,NODRAW;
差60度:=(高点-低点)*60/对角角度;
差45度:=(高点-低点)*45/对角角度;
差55度:=(高点-低点)*55/对角角度;
差50度:=(高点-低点)*50/对角角度;
差65度:=(高点-低点)*65/对角角度;
角度65:IF(TS>=0 AND 低点+(差65度/天数横线)*TS<=高点,低点+(差65度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度50:IF(TS>=0 AND 低点+(差50度/天数横线)*TS<=高点,低点+(差50度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度55:IF(TS>=0 AND 低点+(差55度/天数横线)*TS<=高点,低点+(差55度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
对角线:IF(TS>=0 AND 低点+差*TS<=高点,低点+差*TS,DRAWNULL),COLORYELLOW,LINETHICK2;
角度60:IF(TS>=0 AND 低点+(差60度/天数横线)*TS<=高点,低点+(差60度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度45:IF(TS>=0 AND 低点+(差45度/天数横线)*TS<=高点,低点+(差45度/天数横线)*TS,DRAWNULL),COLORGREEN,LINETHICK1;
收盘角度:(收盘差*对角角度)/对角差,NODRAW;
收盘线:=IF(TS>=0 AND 低点+(收盘差/天数横线)*TS<=高点,低点+(收盘差/天数横线)*TS,DRAWNULL);
差40度:=(高点-低点)*40/对角角度;
差35度:=(高点-低点)*35/对角角度;
差30度:=(高点-低点)*30/对角角度;
差25度:=(高点-低点)*25/对角角度;
差20度:=(高点-低点)*20/对角角度;
差15度:=(高点-低点)*15/对角角度;
角度40:IF(TS>=0 AND 低点+(差40度/天数横线)*TS<=高点,低点+(差40度/天数横线)*TS,DRAWNULL),COLOR008080,LINETHICK1;
角度35:IF(TS>=0 AND 低点+(差35度/天数横线)*TS<=高点,低点+(差35度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度30:IF(TS>=0 AND 低点+(差30度/天数横线)*TS<=高点,低点+(差30度/天数横线)*TS,DRAWNULL),COLORWHITE,LINETHICK1;
角度25:IF(TS>=0 AND 低点+(差25度/天数横线)*TS<=高点,低点+(差25度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度20:IF(TS>=0 AND 低点+(差20度/天数横线)*TS<=高点,低点+(差20度/天数横线)*TS,DRAWNULL),COLORGREEN,LINETHICK2;
角度15:IF(TS>=0 AND 低点+(差15度/天数横线)*TS<=高点,低点+(差15度/天数横线)*TS,DRAWNULL),COLORWHITE,LINETHICK1;

通达信判断低点主图指标公式

 

相关文章