在线检测未来函数

大智慧四象多空指标公式

来源:Internet,编辑:股旁网,2014-03-26

input:n(9),m(3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
AA:=IF(VAR9>100,VAR9-100,0);
BB:=HHV(HIGH,34);
CC:=EMA((VAR6-VAR8)/(BB-VAR8)*100,13);
DD:EMA(0.667*REF(CC,1)+0.333*CC,2),LINETHICK0;
{PARTLINE(DD<REF(DD,1),DD),POINTDOT,colorFFFFFF;
PARTLINE(DD>REF(DD,1),DD),LINETHICK1,color0000FF;}
PARTLINE(DD,DD>REF(DD,1),RGB(255,0,0),DD<REF(DD,1),RGB(255,255,0));
OO:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*80;
EE:3.4*SMA(OO,M,1)-2.1*SMA(SMA(OO,M,1),M,1);
{PARTLINE(EE<REF(EE,1),EE),POINTDOT,colorFFFFFF;
PARTLINE(EE>REF(EE,1),EE),LINETHICK3,color0000FF;}
PARTLINE(EE,EE<REF(EE,1),RGB(255,255,0)),POINTDOT;
PARTLINE(EE,EE>REF(EE,1),RGB(255,0,0)),LINETHICK3;
老阴:=EE<REF(EE,1) AND DD<REF(DD,1);
FILLRGN(EE,DD,老阴,RGB(0,255,0));
老阳:=EE>REF(EE,1) AND DD>REF(DD,1);
FILLRGN(EE,DD,老阳,RGB(255,0,0));
少阳:=EE>REF(EE,1) AND DD<REF(DD,1);
FILLRGN(EE,DD,少阳,RGB(255,255,0));
少阴:=EE<REF(EE,1) AND DD>REF(DD,1);
FILLRGN(EE,DD,少阴,RGB(255,255,0));

大智慧四象多空指标公式

 

相关文章