在线检测未来函数

通达信预知顶底主图指标公式

来源:Internet,编辑:股旁网,2014-03-30

说明:信号有3组:1)中线买:针对中线出现较大跌幅后转强反弹的个股;2)短优共振:指短周期J信号共振买点;3)长优共振:指长周期J信号共振买点。

{顶底}
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
浪顶:IF(T1,A,A),COLORFF00FF,DOTLINE;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
浪底:IF(T2,B,B),COLOR80FF00,DOTLINE;
{判断高低点}
N:=20,200,50;
TS:=BARSLAST(L=LLV(L,N));
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=CONST(开始天数);
低点:DRAWLINE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),1),COLOR00CC00;
高点:DRAWLINE(L=LLV(L,N),CONST(HHV(H,天数横线)),ISLASTBAR,REF(CONST(HHV(H,天数横线)),
TS),1),COLOR00CCCC;
STICKLINE(开始信号,L,CONST(HHV(H,天数横线)),0,0),COLOR00AA00;
{STICKLINE(ISLASTBAR,低点,高点,0,0),COLOR00AA00;}
差:=(高点-低点)/天数横线;
收盘差:=CONST(C)-低点;
对角差:=高点-低点;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFFFF00,NODRAW;
对角线:IF(TS>=0 AND 低点+差*TS<=高点,低点+差*TS,DRAWNULL),COLOR00CCCC,LINETHICK1;
{K线}
C2:=REF(C,1);
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,C,O,3.3,0),COLORBLUE;
STICKLINE(跌停,H,L,0,0),COLORBLUE;
STICKLINE(涨停,C,O,3.3,0),COLOR0077FF;
STICKLINE(涨停,C,O,2.8,0),COLOR0099FF;
STICKLINE(涨停,H,L,0,0),COLOR00FFFF;
{黄金分割线}
{1}
HH1:=HHV(H,200);
LL1:=LLV(L,200);
上涨:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=LL1)+1)),COLOR0000FF,NODRAW;
↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,NODRAW;
最高%:(HH1/REF(L,上涨)-1)*100,COLORFF00FF,NODRAW;
下跌:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=HH1)+1)),COLOR00FF00,NODRAW;
↓空间%:(C/REF(H,下跌)-1)*100,COLOR888899,NODRAW;
最低%:(LL1/REF(H,下跌)-1)*100,COLORFF0000,NODRAW;
天线:REFDATE(REF(H,下跌),DATE),POINTDOT,LINETHICK3,COLORYELLOW;
地线:REFDATE(REF(L,上涨),DATE),POINTDOT,LINETHICK3,COLOR00FF00;
中线:REFDATE((天线-地线)*0.5+地线,DATE),POINTDOT,LINETHICK3,COLOR00FF00;
STICKLINE(上涨=0,天线,地线,0,-1),COLORYELLOW;
STICKLINE(下跌=0,天线,地线,0,-1),COLORGREEN;
DRAWTEXT(下跌=0,地线*1.01,'-最低'),COLOR00FF00;
DRAWTEXT(上涨=0,天线*0.99,'-最高'),COLOR0000FF;
{2}
高:=天线;
低:=地线;
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(下跌=0,高,'高'),COLORGREEN;
DRAWTEXT(下跌=0,H1,'809'),COLORCYAN;
DRAWTEXT(下跌=0,H2,'618'),COLORGRAY;
DRAWTEXT(下跌=0,H3,'中'),COLORYELLOW;
DRAWTEXT(下跌=0,H4,'382'),COLORLIRED;
DRAWTEXT(下跌=0,H5,'191'),COLORMAGENTA;
DRAWTEXT(上涨=0,H1,'风险'),COLORCYAN;
DRAWTEXT(上涨=0,H2,'高位'),COLORGRAY;
DRAWTEXT(上涨=0,H3,'中'),COLORYELLOW;
DRAWTEXT(上涨=0,H4,'低吸'),COLORLIRED;
DRAWTEXT(上涨=0 ,H5,'盘整'),COLORMAGENTA;
DRAWTEXT(上涨=0,低,'低'),COLORRED;
DRAWTEXT(上涨=5,H*1.02,'5'),COLOR00FFFF;
DRAWTEXT(上涨=8,H*1.02,'8'),COLOR00FFFF;
DRAWTEXT(上涨=13,H*1.02,'13'),COLOR00FFFF;
DRAWTEXT(上涨=21,H*1.02,'21'),COLOR00FFFF;
DRAWTEXT(上涨=34,H*1.02,'34'),COLOR00FFFF;
DRAWTEXT(上涨=55,H*1.02,'55'),COLOR00FFFF;
DRAWTEXT(上涨=89,H*1.02,'89'),COLOR00FFFF;
DRAWTEXT(上涨=144,H*1.02,'144'),COLOR00FFFF;
DRAWTEXT(上涨=180,H*1.02,'180'),COLOR00FFFF;
DRAWTEXT(上涨=250,H*1.02,'250'),COLOR00FFFF;
DRAWTEXT(下跌=5,L*0.98,'-5'),COLOR00FF00;
DRAWTEXT(下跌=8,L*0.98,'-8'),COLOR00FF00;
DRAWTEXT(下跌=13,L*0.98,'-13'),COLOR00FF00;
DRAWTEXT(下跌=21,L*0.98,'-21'),COLOR00FF00;
DRAWTEXT(下跌=34,L*0.98,'-34'),COLOR00FF00;
DRAWTEXT(下跌=55,L*0.98,'-55'),COLOR00FF00;
DRAWTEXT(下跌=89,L*0.98,'-89'),COLOR00FF00;
DRAWTEXT(下跌=144,L*0.98,'-144'),COLOR00FF00;
DRAWTEXT(下跌=180,L*0.98,'-180'),COLOR00FF00;
DRAWTEXT(下跌=250,L*0.98,'-250'),COLOR00FF00;
{压力支撑线}
VAR01:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR02:=CROSS(VAR01,0.9);
VAR03:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR04:=CROSS(VAR03,0.9);
压力:=REF(HIGH,BARSLAST(VAR02)), POINTDOT,COLOREA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR02)),REF(HIGH,BARSLAST(VAR02)),2,1),COLOREA91B5,LINETHICK3;
支撑:=REF(LOW,BARSLAST(VAR04)), POINTDOT,COLOR00B4FF;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR04)),REF(LOW,BARSLAST(VAR04)),2,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100)

通达信预知顶底主图指标公式

 

相关文章