在线检测未来函数

飞狐江山胜率指标公式

来源:Internet,编辑:股旁网,2014-04-01

input:N(30,0,1000),M(360,0,1000),M2(360,0,1000),M4(240,0,1000);
VAR1:=(MA(HIGH,N) - LOW) / MA(HIGH,N)* 100;
VAR2:=(SMA(HIGH,N,1) - LOW) / SMA(HIGH,N,1) * 100;
VAR3:=(DMA(HIGH,MA(VOL,N) / CAPITAL) - LOW) / DMA(HIGH,MA(VOL,N) / CAPITAL) * 100;
VAR4:=(COST(N) - LOW) / COST(N) * 100;
VAR5:=100* (HHV(HIGH,20) - LOW) / HHV(HIGH,20);
VAR6:=IF(VAR1 > 0,VAR1,0) * IF(VAR2 > 0,VAR2,0) * IF(VAR3 > 0,VAR3,0) * IF(VAR4 > 0,VAR4,0) * IF(VAR5 > 0,VAR5,0);
VAR7:=100 * (VAR6 - LLV(VAR6,M)) / (HHV(VAR6,M) - LLV(VAR6,M));
VAR8:=SMA(VAR7,3,1);
VAR9:=SMA(VAR8,3,1);
VAR10:=((100 * (VAR9 - LLV(VAR9,M2))) / (HHV(VAR9,M2) - LLV(VAR9,M2)));
平均胜率:IF(VAR10 > 50 AND BARSCOUNT(CLOSE) > M4,VAR10,50),LINETHICK2,colorFFFF;
VAR11:=3 * VAR8 - 2 * VAR9;
VAR12:=100 * (VAR11 - LLV(VAR11,M2)) / (HHV(VAR11,M2) - LLV(VAR11,M2));
江山胜率:IF(VAR12 > 50 AND BARSCOUNT(CLOSE) > M4,VAR12,50),LINETHICK2,colorFFFFFF;
100;
75;

飞狐江山胜率指标公式

 

相关文章