在线检测未来函数

通达信短线雷达选股指标公式

来源:Internet,编辑:股旁网,2014-04-06

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)
AND VAR1;
涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
多头:=DEA<0.09 AND DEA>REF(DEA,1) AND REF(DEA,1)>REF(DEA,2) AND MACD>-2 AND DIFF>DEA;
强势:=DEA<0.15 AND DIFF>REF(DIFF,1) ;
短线支撑:=EMA(EMA((2*L+C)/3,5),7);
操作线:=EMA(SLOPE(CLOSE,20)*20+CLOSE,60);
VAR0:=((-((99)*(HHV(HIGH,11) - CLOSE))/(HHV(HIGH,11) - LLV(LOW,11))));
XG1:=(L<操作线 AND C>操作线 AND VAR0>-30 AND 涨幅>=2.7) AND (多头 {OR 强势});
XG2:=FILTER(VAR19=1,4) AND 涨幅>=3 AND 多头 AND C<操作线*1.12;
{XG2:=(FILTER(VAR19=1,4) AND 涨幅>=3) AND (多头 OR 强势) AND C<操作线*1.12;}
{XG1:=L<操作线 AND C>操作线 AND VAR0>-20 ;
XG2:=FILTER(VAR19=1,4) ;}
A1:=NAMELIKE('ST');
A2:=NAMELIKE('*');
A3:=NAMELIKE('S');
去除停牌:=DYNAINFO(8)>0;
去除ST:=(A1+A2+A3)=0;
巡阳雷达:(XG1 OR XG2 { OR ( CROSS(C,MA(C,5)) AND 涨幅>=3 )}) AND 多头 AND 去除ST && 去除停牌;

通达信短线雷达选股指标公式

 

相关文章