在线检测未来函数

通达信提示提前买卖指标公式

来源:Internet,编辑:股旁网,2014-04-07

STICKLINE(CROSS(20,((SMA(MAX(CLOSE - REF(CLOSE,1),0),7,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),7,1)))*(100)),(-400),0,8,0),COLORRED;
〖明天买入〗:0,COLORRED;
STICKLINE(CROSS(((SMA(MAX(CLOSE - REF(CLOSE,1),0),7,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),7,1)))*(100),80),0,400,8,0),COLOR00FF00;
〖明天卖出〗:0,COLOR00FF00;
VAR1:=(HIGH + LOW + CLOSE)/(3);
VAR2:=(VAR1 - MA(VAR1,14))/((0.015)*(AVEDEV(VAR1,14)));
VAR3:=(VAR1 - MA(VAR1,70))/((0.015)*(AVEDEV(VAR1,70)));
VAR4:=IF((VAR2 >= 150) AND (VAR2 < 200) AND (VAR3 >= 150) AND (VAR3 < 200),100,IF((VAR2 <= (-150)) AND (VAR2 > (-200)) AND (VAR3 <= (-150)) AND (VAR3 > (-200)),(-100),0));
VAR5:=IF((VAR2 >= 150) AND (VAR2 < 200) AND (VAR3 >= 150) AND (VAR3 < 200),100,0);
VAR6:=IF((VAR2 <= (-150)) AND (VAR2 > (-200)) AND (VAR3 <= (-150)) AND (VAR3 > (-200)),(-100),0);
IF((VAR2 >= 200),200,IF((VAR2 <= (-200)),(-200),VAR4)),COLORFFFFFF;
〖测顶〗:0 - IF((VAR3 >= 200),200,VAR5) + 400,COLORYELLOW;
〖测底〗:0 - IF((VAR3 >= 200),0,IF((VAR3 <= (-200)),(-200),VAR6)) - 400,COLORFF00FF;

通达信提示提前买卖指标公式

 

相关文章