在线检测未来函数

通达信大博金主图指标公式

来源:Internet,编辑:股旁网,2014-04-16

A4:=1;
A5:=MA(CLOSE,20);
A6:=A5 + (2 * (STD(CLOSE,20)));
A7:=A5 - (2 * (STD(CLOSE,20)));
A8:=(((AMOUNT / VOL) / 100));
A9:=((REF(CLOSE,1)));
A10:=((IF(((((REF(CLOSE,1)) * 1.1) - CLOSE) < 0.01),1,0)));
STICKLINE(A10,OPEN,CLOSE,5,0),COLORRED;
STICKLINE(A10,OPEN,CLOSE,4,0),COLORYELLOW;
STICKLINE(A10,HIGH,LOW,0,0),COLORYELLOW;
A11:=((((2 * CLOSE) + LOW) + HIGH) / 4) * A4;
A12:=(EMA(A11,40)) * 0.85;
A13:=(3.2 * (SLOPE((EMA(CLOSE,3)),2))) * A4;
A14:=EMA((EMA((EMA((HIGH + A13),3)),4)),4);
操作:(A14 * 0.95) * A4,COLORGREEN;
A15:=(操作);
A16:=REF((REF(操作,1)),1);
A17:=REF((A15 / (REF(操作,1))),1);
A18:=(COUNT(A10,5)) >= 1;
预警:A15 * 1.03;
DRAWTEXT(((A15 / (REF(操作,1))) >= 1.02 AND (OPEN <= 预警)),(LOW * 0.98),'长阳'),COLORFF00FF;
DRAWICON(((A15 / (REF(操作,1))) >= 1.02 AND (OPEN <= 预警)),(LOW * 0.99),10);
A19:=((((3 * CLOSE) + LOW) + OPEN) + HIGH) / 6;
A20:=((((((((((((((((((((20 * A19) + (19 * (REF(A19,1)))) + (18 * (REF(A19,2)))) + (17 * (REF(A19,3)))) + (16 * (REF(A19,4)))) + (15 * (REF(A19,5)))) + (14 * (REF(A19,6)))) + (13 * (REF(A19,7)))) + (12 * (REF(A19,8)))) + (11 * (REF(A19,9)))) + (10 * (REF(A19,10)))) + (9 * (REF(A19,11)))) + (8 * (REF(A19,12)))) + (7 * (REF(A19,13)))) + (6 * (REF(A19,14)))) + (5 * (REF(A19,15)))) + (4 * (REF(A19,16)))) + (3 * (REF(A19,17)))) + (2 * (REF(A19,18)))) + (REF(A19,20))) / 210;
A21:=MA(A19,3);
A22:=SMA(A21,3,1);
A23:=LLV((MA(LOW,3)),13);
A24:=((HHV(A21,13)) * A4);
A25:=REF((HHV(A21,13)) * A4,1);
A26:=REF(A25,1);
STICKLINE(A10,OPEN,CLOSE,8,0),COLORRED;
STICKLINE(A10,OPEN,CLOSE,5,0),COLORYELLOW;
STICKLINE(A10,HIGH,LOW,0,0),COLORYELLOW;
A27:='┄┄┄┄┄';
DRAWTEXT((A8 AND A10),(A8 + 0.06),A27),COLORGREEN;
DRAWTEXT((((OPEN + CLOSE) / 2) AND A10),(((OPEN + CLOSE) / 2) + 0.06),A27),COLORMAGENTA;
DRAWTEXT(A10,(LOW + 0.06),A27),COLORGRAY;
A28:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),2,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),2,1))) * 100;
A29:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),14,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),14,1))) * 100;
A30:=(45);
A31:=(50);
A32:=(80);
A33:=(20);
A34:=(5);
A35:=(A28 < A31) AND ((REF(A28,1)) > A31);
A36:=(A28 < A30) AND ((REF(A28,1)) > A30);
A37:=(A28 < A33) AND ((REF(A28,1)) > A33);
STICKLINE(((A35 * A4) AND A18),OPEN,CLOSE,2,0),COLORFF0000;
STICKLINE(((A36 * A4) AND A18),OPEN,CLOSE,2,0),COLORFF0000;
STICKLINE(((A37 * A4) AND A18),OPEN,CLOSE,2,0),COLORFF0000;
A38:=SMA(LOW,4,3);
STICKLINE(((A38 AND (REF(A36,1))) AND A18),(A38 * 0.9999),(A38 * 0.9979),5,0),COLORGREEN;
STICKLINE(((A38 AND (REF(A37,1))) AND A18),(A38 * 0.9999),(A38 * 0.9979),5,0),COLORGREEN;
STICKLINE(((A15 / (REF(操作,1))) >= 1.02 AND (OPEN <= 预警)),(A38 * 0.9999),(A38 * 0.9979),5,0),COLORGREEN;
A39:=(COUNT(A10,21)) >= 1;
A40:=SMA(HIGH,4,3);
A41:=(A15 / (REF(操作,1))) >= 1;
DRAWTEXT((((A38 AND (REF(A37,1))) AND A18) AND A41),(LOW * 0.98),'回马枪'),COLORGREEN;
DRAWTEXT((((A38 AND (REF(A36,1))) AND A18) AND A41),(LOW * 0.98),'回马枪'),COLORGREEN;
A42:=(((A15 / (REF(操作,1))) > A17));
A43:=(REF(操作,1)) / A16;
A44:=(0.98);
DRAWTEXT((CROSS((A15 / (REF(操作,1))),0.98)),(LOW * 0.970),'抄底'),COLORWHITE;
DRAWICON((CROSS((A15 / (REF(操作,1))),0.98)),(LOW * 0.98),26);
A45:=A40 * A4;
A46:=A38 * A4;
支撑价:LLV(LOW,23) ,COLOR7FFF00,LINETHICK1;
阻力价:HHV(HIGH,23),COLORFF9900, LINETHICK1;
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;

通达信大博金主图指标公式

 

相关文章