在线检测未来函数

通达信私藏抄底主图指标公式

来源:Internet,编辑:股旁网,2014-04-16

DRAWRECTREL(300,382,850,500,RGB(255,255,0));
花:=SLOPE(EMA(C,3),3);
神:=SLOPE(EMA(C,7),7);
DRAWTEXT(COUNT(花<神,5)=4 AND 花>=神,C*0.95,'B'), COLORRED;
DRAWTEXT(COUNT(花>=神,5)=4 AND 花<神,C*1.08,'S'), COLORYELLOW;
STICKLINE(花>= 神 ,CLOSE,OPEN,3.3,0) ,COLOR000077;
STICKLINE(花>= 神 ,CLOSE,OPEN,3.2,0) ,COLOR000099;
STICKLINE(花>= 神 ,CLOSE,OPEN,3.1,0) ,COLOR0000BB;
STICKLINE(花>= 神 ,CLOSE,OPEN,3,0) ,COLOR0000CC;
STICKLINE(花>= 神 ,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(花>= 神 ,CLOSE,OPEN,1,0) ,COLOR0000EE;
STICKLINE(花>= 神 ,CLOSE,OPEN,1,0) ,COLOR0000FF;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.006,1,0),COLOR0000FF;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.005,2,0),,COLOR0000EE;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.004,3,0),COLOR0000DD;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.003,3.1,0),COLOR0000CC;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.002,3.2,0),COLOR0000BB;
STICKLINE(花>= 神 ,CLOSE,CLOSE/1.001,3.3,0),COLOR000099;
STICKLINE(花>= 神 ,OPEN,OPEN*1.006,1,0),COLOR0000FF;
STICKLINE(花>= 神 ,OPEN,OPEN*1.005,2,0),,COLOR0000EE;
STICKLINE(花>= 神 ,OPEN,OPEN*1.004,3,0),COLOR0000DD;
STICKLINE(花>= 神 ,OPEN,OPEN*1.003,3.1,0),COLOR0000CC;
STICKLINE(花>= 神 ,OPEN,OPEN*1.002,3.2,0),COLOR0000BB;
STICKLINE(花>= 神 ,OPEN,OPEN*1.001,3.3,0),COLOR000099;
STICKLINE(花<= 神 ,CLOSE,OPEN/1.006,3.5,0),COLORFF0000;
STICKLINE(花<= 神 ,CLOSE,OPEN/1.005,3.3,0),COLORFF0000;
STICKLINE(花<= 神 ,CLOSE,OPEN/1.004,3.2,0),COLORFF3300;
STICKLINE(花<= 神 ,CLOSE,OPEN/1.003,3,0),COLORFFDD00;
STICKLINE(花<= 神 ,CLOSE,OPEN/1.002,2,0),COLORFFFF00;
EMA13:=EMA(C,20),COLORFF8080;
EMA34:=EMA(C,60),COLORFFFF00;
EMA55:=EMA(C,80),COLORFF00FF;
YZ1:=C/O>1.02 AND H/C>1.02 AND O/L<1.02;
YZ2:=REF(C,1)>REF(O,1) AND O>MA(C,11);
Y:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
YZ:=YZ1 AND YZ2 AND Y>10;
X11:DRAWTEXT(YZ,HIGH+0.2,'减仓'),COLORF00FF0;
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
DRAWTEXT(GR6 AND GR7,H+0.13,'保存利润'),COLOR00FF00;
A1:=EMA(C,14),COLORWHITE,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
支撑位:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL),COLORRED,LINETHICK1;
阻力位:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL),COLORGREEN,LINETHICK1;
STICKLINE(CROSS(A1X,0),C,O,2,0),COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0),COLORGREEN;
DRAWICON(CROSS(花,神) AND CLOSE/REF(CLOSE,1)>1.03,LOW*0.98,25);
花2:=EMA(SLOPE(1,1)+C,3),COLORRED;
神2:=EMA(SLOPE(1,1)+C,7),COLORBLUE;
花1:=MA(CLOSE, 5);
神1:=MA(CLOSE, 60);
花仙:=CROSS(花2,神2) AND 花1>神1;
仙女:=CROSS(神2,花2) AND 花1>神1 AND COUNT(CROSS(花,神) AND 花1>神1 ,30);
DRAWTEXT(花仙,LOW/1.03,'↖买'),COLORWHITE;
DRAWTEXT(仙女,HIGH*1.06,'卖'),COLORYELLOW;
STICKLINE(花仙,CLOSE,O,2,0),COLORYELLOW;
STICKLINE(仙女,CLOSE,O,7,0),COLOR555500;
STICKLINE(仙女,CLOSE,O,6,0),COLOR888800;
STICKLINE(仙女,CLOSE,O,5,0),COLORAAAA00;
STICKLINE(仙女,CLOSE,O,4,0),COLORCCCC00;
STICKLINE(仙女,CLOSE,O,3,0),COLOREEEE00;
STICKLINE(仙女,CLOSE,O,2,0),COLORWHITE;
STICKLINE(花仙,CLOSE,O,4,0),COLOR0000AA;
STICKLINE(花仙,CLOSE,O,3,0),COLOR0000CC;
STICKLINE(花仙,CLOSE,O,2,0),COLOR0000EE;
买入条件:=花仙;
卖出条件:=仙女;
D1:=BARSLAST(买入条件);
D2:=FLOOR(((C-REF(C,D1))/REF(C,D1))*100);
IF(D2>=3 AND D2<7,'5',DRAWNULL);
DRAWTEXT(卖出条件 AND D2=0,LOW,'↙0'),COLORWHITE;
DRAWTEXT(卖出条件 AND D2>0 AND D2<3,HIGH*1.13,'↙赚2%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=3 AND D2<7,HIGH*1.13,'↙赚5%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=7 AND D2<9,HIGH*1.13,'↙赚8%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=9 AND D2<12,HIGH*1.13,'↙赚10%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=12 AND D2<14,HIGH*1.13,'↙赚12%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=14 AND D2<17,HIGH*1.13,'↙赚15%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=17 AND D2<20,HIGH*1.13,'↙赚18%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=20 AND D2<23,HIGH*1.13,'↙赚22%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=23 AND D2<27,HIGH*1.13,'↙赚25%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=27 AND D2<31,HIGH*1.13,'↙赚30%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=31 AND D2<33,HIGH*1.13,'↙赚32%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=33 AND D2<36,HIGH*1.13,'↙赚35%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=36 AND D2<39,HIGH*1.13,'↙赚38%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=39 AND D2<43,HIGH*1.13,'↙赚40%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=43 AND D2<47,HIGH*1.13,'↙赚45%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=47 AND D2<50,HIGH*1.13,'↙赚48%'),COLORRED;
DRAWTEXT(卖出条件 AND D2>=50 AND D2<53,HIGH*1.13,'↙赚50%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=53 AND D2<58,HIGH*1.13,'↙赚55%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=58 AND D2<63,HIGH*1.13,'↙赚60%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=63 AND D2<68,HIGH*1.13,'↙赚65%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=68 AND D2<73,HIGH*1.13,'↙赚70%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=73 AND D2<78,HIGH*1.13,'↙赚75%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=78 AND D2<83,HIGH*1.13,'↙赚80%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=83 AND D2<88,HIGH*1.13,'↙赚85%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=88 AND D2<93,HIGH*1.13,'↙赚90%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=93 AND D2<97,HIGH*1.13,'↙赚95%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=97 AND D2<100,HIGH*1.13,'↙赚99%'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2>=100,HIGH*1.03,'↙100%发了!'),COLORYELLOW;
DRAWTEXT(卖出条件 AND D2<=-1 AND D2>-3,HIGH*1.03,'↙-2%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-3 AND D2>-5,HIGH*1.03,'↙-3%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-5 AND D2>-7,HIGH*1.03,'↙-5%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-7 AND D2>-9,HIGH*1.03,'↙-7%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2=-9 ,HIGH*1.03,'-↙9%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-10 AND D2>-12,HIGH*1.03,'↙-10%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-12 AND D2>-14,HIGH*1.03,'↙-12%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-14 AND D2>-16,HIGH*1.03,'↙-14%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-16 AND D2>-18,HIGH*1.03,'↙-16%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-18 AND D2>-20,HIGH*1.03,'↙-18%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-20 AND D2>-23,HIGH*1.03,'↙-20%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-23 AND D2>-26,HIGH*1.03,'↙-23%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-26 AND D2>-28,HIGH*1.03,'↙-25%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-28 AND D2>-33,HIGH*1.03,'↙-30%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-33 AND D2>-35,HIGH*1.03,'↙-32%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-35 AND D2>-39,HIGH*1.03,'↙-35%'),COLORBLUE;
DRAWTEXT(卖出条件 AND D2<=-39 AND D2>-43,HIGH*1.03,'↙-40%'),COLORBLUE;
DRAWTEXT_FIX(8=8,0,0.86/6,0,'— — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —'),COLORBROWN;
DRAWTEXT_FIX(8=8,0,1.86/6,0,'— — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —'),COLORBROWN;
DRAWTEXT_FIX(8=8,0,2.86/6,0,'— — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —'),COLORBROWN;
DRAWTEXT_FIX(8=8,0,3.86/6,0,'— — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —'),COLORBROWN;
DRAWTEXT_FIX(8=8,0,4.86/6,0,'— — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —'),COLORBROWN;
DRAWTEXT(C>REF(C,1)*1.02 AND V/REF(MA(V,5),1)>2,L*0.98,'正量放大'),COLORYELLOW;

通达信私藏抄底主图指标公式

 

相关文章