在线检测未来函数

通达信涨停伏击主图及选股指标公式

来源:Internet,编辑:股旁网,2014-04-17

N:=10;M:=9;
VAB0:=531;VAB1:=1510000;
VAB2:=VAB0 + VAB1;
A:=SMA(L,4,3) ;
VAB3:=IF(DATE > VAB2,0,1);
{DRAWTEXT(均价线 AND 涨停,均价线,B1),COLORGREEN;}
T:=DATE>901224 AND DATE<1130630;
涨停:=IF(REF(C,1)*1.1*VAB3-C<0.01 ,1,0);
R1:=(C+L+H)/3;
R2:=EMA(R1,6);
R3:=EMA(R2,5);
联邦私募8号:EMA(R3,17),COLOR00AAFF,LINETHICK1;
单阳:=IF(REF(C,1)*1.1*VAB3-C<0.01 ,1,0)*T;
高不破价:=REF(C,BARSLAST(单阳));
中不破价:=REF((C+L)/2,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
STICKLINE(单阳,O,C,1.5,0),COLORYELLOW;
MA17:=MA(C,17),COLOR0000FF;
MA55:MA(C,55),COLORFF00FF,LINETHICK2;
支撑线:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORFFFFFF;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,COLORWHITE,LINETHICK2;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,COLORGRAY;
震仓线:=45,COLORMAGENTA;
震仓线2:=50,COLORGRAY;
逃命线:=80,COLORRED;
抄底线:=20,COLORGREEN;
绝底线:=5,COLORBLUE;
VARA12:=SMA(H,10,9)*VAB3;
VARA13:=SMA(L,10,9)*VAB3;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
HD:=COUNT(涨停,21)>=1;
A1:=SMA(H,N,M);
A2:=SMA(L,N,M);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
卖出价参考:VARA12,COLORRED,NODRAW;
补仓价参考:VARA13,COLORGREEN,NODRAW;
T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
XG:=T1 AND T2 AND T3 AND T5 AND T6;
DRAWTEXT(XG,L*0.99,'伏击'),COLOR00FF00;
DRAWICON(XG,L*0.9995,1);

{
选股公式:

T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
T1 AND T2 AND T3 AND T5 AND T6;
}

通达信涨停伏击主图及选股指标公式

 

相关文章