在线检测未来函数

大智慧神偷再现指标公式

来源:Internet,编辑:股旁网,2014-04-18

M:=3;
VAR1N:=1990131;
U1:=IF((DATE <= VAR1N),1,0);
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) * U1);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
神偷线:(((DMP * U1) * 100) / TR);
辅助线:=((DMM * 100) / TR);
动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),M) * U1);
ADXR:=((动向趋势线 + REF(动向趋势线,M)) / 2);
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR7:=REF(VAR3,1);
【强弱】:=((SMA(MAX((VAR3 - VAR7),0),5,1) / SMA(ABS((VAR3 - VAR7)),5,1)) * 100);
预警:(IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),20,0) * U1),LINETHICK1,COLORFF00FF;
短底:5,LINETHICK2,COLORBLUE;
短顶:43,COLORGREEN;
绝顶:60,LINETHICK2,COLORFF00FF;
FILLRGN(神偷线,短底,神偷线<=短底,RGB(255,0,0));
FILLRGN(神偷线,短顶,神偷线>=短顶,RGB(255,0,0));
FILLRGN(神偷线,绝顶,神偷线>=绝顶),colorgreen;

大智慧神偷再现指标公式

 

相关文章