在线检测未来函数

飞狐江山快损赢指标公式

来源:Internet,编辑:股旁网,2014-04-24

input:简单(2,0,100),滑动(2,0,100),移动(2,0,100),加权(2,0,100);
止损:= MA(LOW,简单);
简损:IF(简止损 > REF(简止损,1),简止损,REF(简止损,BARSLAST(简止损 > REF(简止损,1)))),LINETHICK2,colorFF;
滑止损:=EMA(LOW,滑动);
滑损:IF(滑止损 > REF(滑止损,1),滑止损,REF(滑止损,BARSLAST(滑止损 > REF(滑止损,1)))),LINETHICK2,colorFFFF;
移止损:=SMA(LOW,移动,1);
移损:IF(移止损 > REF(移止损,1),移止损,REF(移止损,BARSLAST(移止损 > REF(移止损,1)))),LINETHICK2,colorFFFFFF;
权止损:= WMA(LOW,加权);
权损:IF(权止损 > REF(权止损,1),权止损,REF(权止损,BARSLAST(权止损 > REF(权止损,1)))),LINETHICK2,colorFF00;
EXPLAINEX(c,'简止损价',简损,2,0),colorFF;
EXPLAINEX(c,'滑止损价',滑损,2,0),colorFFFF;
EXPLAINEX(c,'移止损价',移损,2,0),colorFFFFFF;
EXPLAINEX(c,'权止损价',权损,2,0),colorFF00;
EXPLAINEX(c,'平均止损',(移损 + 权损 + 滑损 + 简损) / 4,2,0),colorFF0000;
EXPLAIN(CROSS((移损 + 权损 + 滑损 + 简损) / 4,CLOSE),'跌破止损价'),colorFFFF00;
止赢:=MA(HIGH,简单);
简赢:IF(简止赢 > REF(简止赢,1),简止赢,REF(简止赢,BARSLAST(简止赢 > REF(简止赢,1)))),CROSSDOT,colorFF;
滑止赢:=EMA(HIGH,滑动);
滑赢:IF(滑止赢 > REF(滑止赢,1),滑止赢,REF(滑止赢,BARSLAST(滑止赢 > REF(滑止赢,1)))),CROSSDOT,colorFFFF;
移止赢:=SMA(HIGH,移动,1);
移赢:IF(移止赢 > REF(移止赢,1),移止赢,REF(移止赢,BARSLAST(移止赢 > REF(移止赢,1)))),CROSSDOT,colorFFFFFF;
权止赢:=WMA(HIGH,加权);
权赢:IF(权止赢 > REF(权止赢,1),权止赢,REF(权止赢,BARSLAST(权止赢 > REF(权止赢,1)))),CROSSDOT,colorFF00;
EXPLAINEX(c,'简止赢价',简赢,2,0),colorFF;
EXPLAINEX(c,'滑止赢价',滑赢,2,0),colorFFFF;
EXPLAINEX(c,'移止赢价',移赢,2,0),colorFFFFFF;
EXPLAINEX(c,'权止赢价',权赢,2,0),colorFF00;
EXPLAINEX(c,'平均止赢',(移赢 + 权赢 + 滑赢 + 简赢) / 4,2,0),colorFF0000;
EXPLAIN(CROSS(CLOSE,移赢 + 权赢 + 滑赢 + 简赢) / 4,'突破止赢价'),colorFFFF00;

飞狐江山快损赢指标公式

 

相关文章