在线检测未来函数

通达信三合一指标公式

来源:Internet,编辑:股旁网,2014-04-29

N:=100;
AAA:=(N*"MACD.MACD");
STICKLINE(AAA>0 AND AAA>REF(AAA,1) ,50,50+AAA,2.5,0),COLORRED;
STICKLINE(AAA>0 AND AAA<REF(AAA,1),50,50+AAA,2.5,1),COLORYELLOW;
STICKLINE(AAA<0 AND AAA>REF(AAA,1),50,50+AAA,2.5,1),COLORMAGENTA;
STICKLINE(AAA<0 AND AAA<REF(AAA,1),50,50+AAA,2.5,0),COLORWHITE;
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR111:=EMA(VAR10,30);
VAR12:=VAR111-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR11:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
VAR22:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR33:=IF(ABS(VAR1)<2,0.9,1);
VAR44:=VAR33*(VAR22-VAR11);
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<25 AND VAR15<30 AND VAR16>50,70,0);
★发射: VAR20,LINETHICK0,COLORRED;
预警系统:IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60,LINETHICK0;
AA:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
AA1:=MA(VOL,8)/MA(VOL,45)>=2.5;
AA2:=MA(HIGH,13);
AA3:=MA(CLOSE,13);
AA4:=MA(AMOUNT/VOL,13)/100;
AA5:=MA(LOW,13);
AA6:=MA(AMOUNT/VOL,30)/100;
AA7:=MA(AMOUNT/VOL/100,13)*0.85;
AA8:=FILTER((AA2>REF(AA2,1)*1.015 AND AA5>REF(AA5,1)*1.015 AND AA3>REF(AA3,1)*1.015 AND AA4>REF(AA4,1)*1.015 ),5);
高位买:=(C>0 AND FINANCE(33)>0 AND (AA OR AA8))*20,LINETHICK0,COLORFF00FF;
盘:=CAPITAL/1000000;
益:=FINANCE(33);
资:=FINANCE(34);
换手:=VOL/CAPITAL;
长阳:=(WINNER(C)-WINNER(O))>=0.15 AND 换手<=0.04;
缩量长阳:=IF(长阳,(WINNER(C)-WINNER(O))*100,0);
VVAR1:=(C-REF(C,1))/REF(C,1);
VVAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VVAR1,20),5);
大盘:=EMA(SUM(VVAR2,20),5);
领涨:=(个股-大盘)>=0;
VVAR3:=(C-LLV(L,125))/(HHV(H,125)-LLV(L,125))*100;
VVAR4:=SMA(VVAR3,72,1);
VVAR5:=SMA(VVAR4,34,1);
中线趋势:=3*VVAR4-2*VVAR5;
中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,5)-REF(MA(C,5),1))>=0;
均十升:=(MA(C,10)-REF(MA(C,10),1))>=0;
领涨大盘:=IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),COLORFF99FF;
VVAR6:=(2*C+H+L)/4;
VVAR7:=LLV(L,27);
VVAR8:=HHV(H,27);
攀登:=(EMA((VVAR6-VVAR7)/(VVAR8-VVAR7)*100,13)-15)*1.6;
金山:=EMA(0.618*REF(攀登,1)+0.382*攀登,3);
强弱界:=0,COLORFFFF00;
运动员:=IF(攀登>=金山 AND 均五升 AND 均十升 AND 中线趋势升 AND 金山<35,1,0);
起步:IF(CROSS(攀登,金山) AND 金山<30,10,0),COLORRED;
起攀:IF(运动员=1 AND COUNT(运动员=1,5)=1,8,0),COLORFF9999,LINETHICK1;
超短买:=缩量长阳,LINETHICK0,COLOR60FFFF;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
抄底:=IF(起攀=8 AND COUNT(乖离<-12,10)>=1,10,0),LINETHICK0,COLORRED;
天:=IF(VARB<90,VARB,100);
地:= IF(VAR1>0,VAR1,0);
基地:= IF(VAR1<0,VAR2,0);
STICKLINE(基地>=REF(基地,1),0,基地,3,0),COLORLIGREEN;
STICKLINE(基地<REF(基地,1),0,基地,3,0),COLORGREEN;
STICKLINE(基地,0,-(基地)*0.3,3,0),COLORGREEN;
STICKLINE(基地<REF(基地,1),-(基地)*0.3,0,3,0),COLORLIGREEN;
STICKLINE(★发射>0,15,★发射*1.1,0,0),POINTDOT,COLORWHITE;
STICKLINE(★发射>0 AND ★发射<400,40,★发射,0,1),COLORRED,LINETHICK1;
STICKLINE(★发射>0,15,★发射*0.7,1.5,0),COLORFFA4A6,LINETHICK5;
STICKLINE(★发射>0,15,★发射*0.1,3,0),COLOR0099CC,LINETHICK7;
STICKLINE(★发射>0,15,0,5,0),COLORRED,LINETHICK6;
量:V/CONST(HHV(V,90))*40,LINETHICK0,VOLSTICK;
T1:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
T2:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
T3:=地>50 AND 预警系统>60 AND 天 =100;
T4:=地>48 AND 预警系统>60 AND 天<100;
T5:=基地>38 AND 预警系统<55;
T6:=★发射>50 AND 天<90;
T7:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
T8:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND ★发射=0 AND 基地>REF(基地,1) AND VARC<REF(VARD,1);
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,0-0.5,1,1),COLORFFFF00,LINETHICK4;
STICKLINE(攀登>=金山 AND 均五升 AND 均十升
AND 中线趋势升 ,金山-3,金山-7,2,0),COLOR00A0E6 ;
STICKLINE(攀登>金山 AND 攀登>=REF(攀登,1)
,攀登+5,金山-1,1.2,0),COLORRED,LINETHICK2;
STICKLINE(攀登>金山 AND 攀登<REF(攀登,1)
,攀登,攀登,1.2,0),COLORWHITE,LINETHICK2;
STICKLINE(攀登<金山,金山+0.5,金山-0.5,1.5,0),COLORFFFF00,LINETHICK2;
STICKLINE(领涨大盘=4,攀登+6,金山-1,2,0),COLORFF99FF;
STICKLINE(必抄底=10,10,0,5,1),COLORRED;
DRAWTEXT(均五升 AND 均十升 AND 中线趋势升 AND 领涨 ,4,'ˉ'),COLORFF99FF;
DRAWTEXT(预警系统=75,75,'↓'),COLOR0000FF;
{DRAWTEXT(预警系统=50,75,'↑'),COLOR00FFFF;}
STICKLINE(预警系统=50,70,80,0,0),COLORRED,LINETHICK1;
STICKLINE(预警系统=50,70,70+7,3,0),COLORFFA4A6;
STICKLINE(预警系统=50,70,70+2,5,0),COLORRED,LINETHICK7;
DRAWTEXT(必抄底=10,30,'★←必抄底'),COLORRED;
KKK:50+(N*"MACD.DIF");
DDD:50+(N*"MACD.DEA");
起:IF(CROSS(攀登,金山) AND 金山<30,10,0),COLORRED;
起登:IF(运动员=1 AND COUNT(运动员=1,5)=1,8,0),COLORFF9999,LINETHICK1;

通达信三合一指标公式

 

相关文章