在线检测未来函数

通达信潜伏启动线指标公式

来源:Internet,编辑:股旁网,2014-04-27

强势线:2,LINETHICK2,COLORFF00FF;
准强线:1.3,LINETHICK1,COLOR00FF00;
UP:=( C > O OR C > REF(C,1)) AND V > REF(V,1);
AA:=COUNT(UP,3)=3;
BB:=LLV(L,5)=LLV(L,120);
CC:=C > MA(C,3);
LLT:=AA AND BB AND CC;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
警戒线:3.1,LINETHICK3,COLOR00FFFF;
高抛线:3.5,LINETHICK2,COLOR0000FF;
指导线:EMA((C-V1)/(V2-V1)*4,4);
M5:=MA(指导线,5);
低吸线:0.3,LINETHICK1,COLORWHITE;
VAR2:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
VAR3:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR4:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR5:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR6:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
VAR7:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
VAR8:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6;
VARA:=EMA(VAR9,3);
VARB:=ABS(VAR6-VAR8);
VARC:=(VAR9+VARB)/2;
VARD:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VARE:=VARD+VARC;
VARF:=IF(VAR2>0 AND VARE<0,200,0);
VAR10:=IF(VARC<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
VAR11:=IF(VARE<0 AND VAR10=-50,100,0);
VAR12:=MA(CLOSE,3);
VAR13:=REF(CLOSE,2)*0.865;
VAR14:=REF(CLOSE,13)*0.772;
VAR15:=MIN(VAR13,VAR14);
VAR16:=100*VOL/CAPITAL;
VAR17:=MA(CLOSE,13);
VAR18:=IF((CLOSE-VAR15)/CLOSE<0.03 AND SUM(VAR16,5)/5<1.8,1,0);
VAR19:=IF(VAR18>0 AND (VAR10<0 OR VAR2>0),100,0);
VAR1A:=VAR19;
VAR1B:=IF(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND(VAR10<0 OR VAR2>0) AND VAR19<10,50,0);
VAR1C:=(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0);
VAR1D:=VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
大底区域 : ( VAR1C OR VAR1D )*3,LINETHICK2,COLORRED;

通达信潜伏启动线指标公式

 

相关文章