在线检测未来函数

通达信金蝉脱壳指标公式

来源:Internet,编辑:股旁网,2014-05-03

N:=-6;
VAR1:=HHV(HIGH,21);
VAR2:=LLV(LOW,21);
VAR3:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);
VAR4:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20);
IF(CROSS(VAR4,VAR3) AND VAR3>55,100,115);
VAR6:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR7:=SMA(VAR6,3,1);
VAR8:=SMA(VAR7,3,1);
VAR9:=3*VAR7-2*VAR8;
VARA:=LLV(LOW,5);
VARB:=HHV(HIGH,5);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*100,4)*2;
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=3*VARC-2*VARD;
VARF:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR10:=POW(MA(LOW,5),2)+MA(LOW,5);
VAR11:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VAR12:=(VARF-LLV(VAR10,64))/(HHV(VAR11,64)-LLV(VAR10,64))*150+65-10;
VAR13:=SMA(VAR12,3,1)*1.5-100;
VAR14:=SMA(VAR13,3,1);
VAR15:=3*VAR13-2*VAR14;
VAR16:=(HIGH+LOW+CLOSE*2)/4;
VAR17:=EMA(VAR16,13);
VAR18:=STD(VAR16,13);
VAR19:=(VAR16-VAR17)*100/VAR18;
VAR1A:=EMA(VAR19,5);
VAR1B:=EMA(VAR1A,13);
VAR1C:=EMA(VAR1A,13)+200-100;
VAR1D:=EMA(VAR1C,10);
VAR1E:=3*VAR1C-2*VAR1D;
VAR1F:=VAR7+VARC+VAR13+VAR1C;
VAR20:=VAR8+VARD+VAR14+VAR1D;
VAR21:=VAR9+VARE+VAR15+VAR1E;
VAR22:=(HIGH+LOW+CLOSE)/3;
VAR23:=AMOUNT/VOL/100;
VAR24:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR25:=(VAR22-MA(VAR22,34))/(0.015*AVEDEV(VAR22,34));
VAR26:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR27:=(HIGH+LOW+CLOSE+VAR22)/4;
VAR28:=EMA(VAR27,24);
VAR29:=STD(VAR27,24);
VAR2A:=(VAR27-VAR28)/VAR29*100;
VAR2B:=(VAR22-MA(VAR22,24))/(0.015*AVEDEV(VAR22,24));
VAR2C:=EMA(VAR2A,5);
VAR2D:=(VAR23-MA(VAR23,21))/(0.015*AVEDEV(VAR23,21));
VAR2E:=(VAR24-MA(VAR24,90))/(0.015*AVEDEV(VAR24,90));
VAR2F:=((VAR2C+VAR2B+VAR25)/3+165)/4;
VAR30:=(EMA(EMA(EMA(VAR2F,15),10),5)-25)*2+VAR26;
VAR31:=(VAR1F+VAR20+VAR21*30)/32/5-15;
VAR32:=EMA(VAR31,13);
VAR33:=(VAR2F+VAR31)/2/1.1;
VAR34:=VAR33;
价位线: EMA(VAR34,1),COLORFFFF00;
VAR35:=EMA(价位线,12);
趋势线: EMA((VAR30+VAR32)/2,2),LINETHICK2;
VAR36:=EMA(趋势线,34);
VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR3A:=(VAR37+2*VAR38+3*VAR39)/6;
VAR3B:=MA(VAR3A,3);
IF(VAR3B<N,0,-35),COLORGREEN;
VAR3C:=CROSS(价位线,0) AND COUNT(VAR3B<-12,2)>=1 OR CROSS(价位线,趋势线) AND COUNT(VAR3B<-12,2)>=1;
VAR3D:=STICKLINE(VAR3C,100,0,3,0);
DRAWICON(VAR3C,100,1);
DRAWICON(CROSS(价位线,趋势线) AND COUNT(VAR3B<N,2)>=1 OR CROSS(价位线,0) AND COUNT(VAR3B<N,1)>=1,-5,1);

通达信金蝉脱壳指标公式

 

相关文章