在线检测未来函数

通达信顶底优化指标公式

来源:Internet,编辑:股旁网,2014-05-06

底: 0,POINTDOT, LINETHICK4, COLORYELLOW;
顶1: 107,POINTDOT, LINETHICK4, COLORFFFF00;
顶2: 108,POINTDOT, LINETHICK4, COLOR000000;
VAR2:=IF(MONTH<12,1,1);
VAR3:=(3*CLOSE+HIGH+LOW)/5;
VAR4X:=LLV(LOW,10);
VAR5X:=HHV(HIGH,10);
进X:MA((VAR3-VAR4X)/(VAR5X-VAR4X)*100,8),LINETHICK3,COLORRED;
退X:MA(0.667*REF(进X,1)+0.333*进X,2),LINETHICK3,COLORBLUE;
VAR4:=LLV(LOW,16);
VAR5:=HHV(HIGH,16);
进:=MA((VAR3-VAR4)/(VAR5-VAR4)*100,12)*VAR2,LINETHICK2,COLORRED;
退:=MA(0.667*REF(进,1)+0.333*进,3),LINETHICK2,COLORBLUE;
DRAWTEXT(CROSS(进,退) AND 退<25,18,'启动'),LINETHICK1,COLOR00FFFF;
DRAWICON(CROSS(进,退) AND 退<25,25,1);
DRAWTEXT(CROSS(进X,退X) AND 退X<22,16,'大底'),LINETHICK1,COLOR0000FF;
DRAWICON(CROSS(进X,退X) AND 退X<22,23,1);
DRAWTEXT(CROSS(进,28) AND C>REF(C,1) AND 退<进,30,'上扬 '),LINETHICK1,COLOR00CCFF;
DRAWICON(CROSS(进,28) AND C>REF(C,1) AND 退<进,25,1);
DRAWTEXT(CROSS(进X,57) AND 退X<进X,54,'冲击 '),LINETHICK1,COLOR9933FF;
DRAWICON(CROSS(进X,57) AND 退X<进X,49,1);
DRAWTEXT(CROSS(进,77) AND C<REF(C,1)*1.045 AND 退<进,70,'防套'),LINETHICK2,COLORFFFFFF;
DRAWICON(CROSS(进,77) AND C<REF(C,1)*1.045 AND 退<进,76,2);
DRAWTEXT(CROSS(退X,进X) AND 退>73,88,'头部'), ,COLOR00FF00;
DRAWICON(CROSS(退X,进X) AND 退>73,92,2);
底部:IF(CROSS(进,退*0.98) AND 进<45,50,5),LINETHICK2,COLORRED;
顶部:IF(CROSS(退X*1.02,进X) AND 进X>73,71,102),LINETHICK2,COLORGREEN;

通达信顶底优化指标公式

 

相关文章