在线检测未来函数

通达信MACD起涨指标公式

来源:Internet,编辑:股旁网,2014-05-07

SHORT:=12;
LONG:=27;
MID:=9;
DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIFF,MID);
MACD:=2*(DIFF-DEA);
MACD上拐:= REF(MACD,1)<REF(MACD,2) AND REF(MACD,1)<MACD AND REF(DIFF,1)<REF(DIFF,2);
MACD下拐:= REF(MACD,1)>REF(MACD,2) AND REF(MACD,1)>MACD;
DIFF上拐:={REF(DIFF,4)<REF(DIFF,3) AND REF(DIFF,3)<REF(DIFF,2) AND} REF(DIFF,1)<REF(DIFF,2) AND REF(DIFF,1)<DIFF;
DIFF短调再上:={REF(DIFF,4)<REF(DIFF,3) AND} REF(DIFF,3)<REF(DIFF,2) AND REF(DIFF,1)<REF(DIFF,2) AND REF(DIFF,1)<DIFF;
DIFF在DEA上:={REF(DEA,4)<REF(DIFF,4) AND} REF(DEA,3)<REF(DIFF,3) AND REF(DEA,2)<REF(DIFF,2) AND REF(DEA,1)<REF(DIFF,1) AND DEA<DIFF;
放量起涨:= V>REF(V,1)*1.618;
BUYDIFF再上:IF(DIFF短调再上 {AND DIFF在DEA上} {AND 放量起涨},1,0),COLORBLUE;
BUYDIF上拐:IF(DIFF上拐 AND NOT(BUYDIFF再上),1.1,0.1),COLORRED;
BUYMACD上拐:IF(MACD上拐,2.3,1.3),COLORMAGENTA;
SELLMACD下拐:IF(MACD下拐,4,5),COLOR008000;

通达信MACD起涨指标公式

 

相关文章