在线检测未来函数

通达信MACD彩柱指标公式

来源:Internet,编辑:股旁网,2014-05-08

short:=12;
long:=26;
mid:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>0,MACD,0,0.01,0),COLORRED,,LINETHICK2;
STICKLINE(MACD<0,MACD,0,0.01,0),COLORCYAN;
STICKLINE(MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND MACD<0,MACD,0,0.01,0),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND MACD>0,MACD,0,0.01,0),COLORGREEN;
STICKLINE(MACD>REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND MACD<0,MACD,0,0.01,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND MACD>0,MACD,0,0.01,0),COLORYELLOW;

通达信MACD彩柱指标公式

 

相关文章