在线检测未来函数

通达信心理意愿指标公式

来源:Internet,编辑:股旁网,2014-05-10

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:=(主力-均量);
大户能量:=(大户-均量);
中户能量:=(中户-均量);
散户能量:=(散户-均量);
当日意愿:=(ABS(主力能量)+ABS(大户能量)+ABS(中户能量)+ABS(散户能量))*10;
VAR1:=(C-MA(C,6))/MA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
VAR5:=EMA(VAR4,5);
VAR6:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VAR7:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR8:=VAR7<REF(VAR7,1) AND V>REF(V,1) AND C>REF(C,1);
K:=EMA(VAR5,5)*4;
D:=EMA(K,5);
J:=K*3-D*2;
机构意愿:主力能量,NODRAW;
游资意愿:大户能量,NODRAW;
大户意愿:中户能量,NODRAW;
散户意愿:散户能量,NODRAW;
市场意愿:LLV(VAR6,3)<VAR6,NODRAW;
主流意愿:J>D,NODRAW;
空方意愿:=VAR8>0,NODRAW;
STICKLINE(CLOSE,0,100,4,1),COLORWHITE;
STICKLINE(CLOSE,0,75,4,1),COLORWHITE;
STICKLINE(CLOSE,0,50,4,1),COLORWHITE;
STICKLINE(CLOSE,0,25,4,1),COLORWHITE;
STICKLINE(CLOSE,-25,-100,4,1),COLORWHITE;
STICKLINE(CLOSE,-25,-75,4,1),COLORWHITE;
STICKLINE(CLOSE,-25,-50,4,1),COLORWHITE;
STICKLINE(散户能量>=0,5,20,3,0),COLOR0000AA;
STICKLINE(散户能量>=0,5,20,2,0),COLOR0000CC;
STICKLINE(散户能量>=0,5,20,1,0),COLOR0000DD;
STICKLINE(散户能量<0,5,20,3,0),COLOR007B00;
STICKLINE(散户能量<0,5,20,2,0),COLOR009000;
STICKLINE(散户能量<0,5,20,1,0),COLOR00A800;
DRAWTEXT(ISLASTBAR=1,12.5,'散户意愿'),COLORGREEN;
STICKLINE(中户能量>=0,30,45,3,0),COLOR0000AA;
STICKLINE(中户能量>=0,30,45,2,0),COLOR0000CC;
STICKLINE(中户能量>=0,30,45,1,0),COLOR0000DD;
STICKLINE(中户能量<0,30,45,3,0),COLOR007B00;
STICKLINE(中户能量<0,30,45,2,0),COLOR009000;
STICKLINE(中户能量<0,30,45,1,0),COLOR00A800;
DRAWTEXT(ISLASTBAR=1,37.5,'大户意愿'),COLORMAGENTA;
STICKLINE(大户能量>=0,55,70,3,0),COLOR0000AA;
STICKLINE(大户能量>=0,55,70,2,0),COLOR0000CC;
STICKLINE(大户能量>=0,55,70,1,0),COLOR0000DD;
STICKLINE(大户能量<0,55,70,3,0),COLOR007B00;
STICKLINE(大户能量<0,55,70,2,0),COLOR009000;
STICKLINE(大户能量<0,55,70,1,0),COLOR00A800;
DRAWTEXT(ISLASTBAR=1,62.5,'游资意愿'),COLORYELLOW;
STICKLINE(主力能量>=0,80,95,3,0),COLOR0000AA;
STICKLINE(主力能量>=0,80,95,2,0),COLOR0000CC;
STICKLINE(主力能量>=0,80,95,1,0),COLOR0000DD;
STICKLINE(主力能量<0,80,95,3,0),COLOR007B00;
STICKLINE(主力能量<0,80,95,2,0),COLOR009000;
STICKLINE(主力能量<0,80,95,1,0),COLOR00A800;
DRAWTEXT(ISLASTBAR=1,87.5,'机构意愿'),COLORWHITE;
STICKLINE(VAR6=LLV(VAR6,3),-80,-95,3,0),COLORGREEN;
STICKLINE(LLV(VAR6,3)<VAR6,-80,-95,3,0),COLORRED;
DRAWTEXT(ISLASTBAR=1,-87.5,'市场意愿'),COLORWHITE;
STICKLINE(J<D,-55,-70,3,0),COLORCYAN;
STICKLINE(J>D,-55,-70,3,0),COLORMAGENTA;
DRAWTEXT(ISLASTBAR=1,-62.5,'主流意愿'),COLORRED;
STICKLINE(VAR8=0,-30,-45,3,0),COLOR6B8E23;
STICKLINE(VAR8>0,-30,-45,3,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR=1,-37.5,'空方意愿'),COLORBLUE;

通达信心理意愿指标公式

 

相关文章