在线检测未来函数

飞狐金兰穿越主图指标公式

来源:Internet,编辑:股旁网,2014-05-12

INPUT:N(80,1,999),M(3,1,15);
操作线:MA(C,13),COLORMAGENTA,LINETHICK0;
A0:=(L+H+C*2)/4;
AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;
BB:=EMA(A0,3)COLORYELLOW,LINETHICK2;
A1X:=(AA-REF(AA,1))/REF(AA,1)*100;
A2X:=(BB-REF(BB,1))/REF(BB,1)*100;
G:=BARSLAST(CROSS(A1X,0));
G1:=BARSLAST(CROSS(A2X,0));
必卖止损:REF(A0,G),ColorFFDDD3,LINETHICK1;
止赢:REF(A0,G1),COLORCYAN,LINETHICK1;
中浪:FORCAST(FORCAST(BB,30),30),COLORYELLOW,LINETHICK0;
强弱值:FORCAST(MA(LLV(CLOSE,1),2),2),COLORRED,SHIFT1;
FS:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),colorf4e202,linethick0;
CG:IF(MA(CLOSE,17)<FS,FS,MA(CLOSE,17)),colorf4e202,linethick0;
A:cg-(ema(c,3)-cg),colorff8080,LINETHICK2;
PARTLINE(操作线>A,操作线),COLORMAGENTA,LINETHICK2;
PARTLINE(操作线>A,A),COLORRED,LINETHICK2;
PARTLINE(操作线<A,操作线),COLORGREEN,LINETHICK2;
PARTLINE(强弱值>中浪,中浪),Color0076FF,,LINEDOT;
PARTLINE(强弱值<中浪,中浪),Color80B002,,LINEDOT;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=0.90*(DIFF-DEA);
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
STICKLINE(TJ,H,L,0.4,0),COLORYELLOW;
STICKLINE(TJ,O,C,4,0),COLOR0088FF;
STICKLINE(TJ,O,C,3.4,0),COLOR00AAFF;
STICKLINE(TJ,O,C,2.8,0),COLOR00CCFF;
STICKLINE(TJ,O,C,2,0),COLOR00DDFF;
STICKLINE(TJ,O,C,1.2,0),COLOR55FFFF;
STICKLINE(TJ,O,C,0.4,0),COLOR99FFFF;
STICKLINE(TJ1 AND TJ,H,L,0.4,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,4,0),COLORFF33FF;
STICKLINE(TJ1 AND TJ,O,C,3.4,0),COLORFF55FF;
STICKLINE(TJ1 AND TJ,O,C,2.8,0),COLORFF77FF;
STICKLINE(TJ1 AND TJ,O,C,2,0),COLORFF99FF;
STICKLINE(TJ1 AND TJ,O,C,1.2,0),COLORFFBBFF;
STICKLINE(TJ1 AND TJ,O,C,0.4,0),COLORFFDDFF;
STICKLINE(DIFF<DEA,H,L,0.4,0),COLORF0F000;
STICKLINE(DIFF<DEA,O,C,4,0),COLORFF3300;
STICKLINE(DIFF<DEA,O,C,3.4,0),COLORFF6600;
STICKLINE(DIFF<DEA,O,C,2.8,0),COLORFF9900;
STICKLINE(DIFF<DEA,O,C,2,0),COLORFFBB00;
STICKLINE(DIFF<DEA,O,C,1.2,0),COLORFFDD00;
STICKLINE(DIFF<DEA,O,C,0.4,0),COLORFFFF00;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
SJ:=(CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03)OR(CROSS(SK,SD)
AND SK<=-0.14 )OR(CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035));
STICKLINE(SJ,H,L,0.5,0),COLORRED;
STICKLINE(SJ,O,C,5.5,0),LINETHICK3,COLOR000055;
STICKLINE(SJ,O,C,4.5,0),LINETHICK3,COLOR000077;
STICKLINE(SJ,O,C,3.5,0),LINETHICK3,COLOR000099;
STICKLINE(SJ,O,C,2.5,0),LINETHICK3,COLOR0000BB;
STICKLINE(SJ,O,C,1.5,0),LINETHICK3,COLOR0000DD;
STICKLINE(SJ,O,C,0.5,0),LINETHICK3,COLOR0000FF;
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'短进'),PXUP4,Color00FFFF;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'短出'),ColorFF5000;

飞狐金兰穿越主图指标公式

 

相关文章