在线检测未来函数

通达信方向助力指标公式

来源:Internet,编辑:股旁网,2014-05-14

STICKLINE(c>0,0,0,10,0),COLORBLUE;
STICKLINE(c>0,25,25,10,0),COLORGRAY;
STICKLINE(c>0,75,75,10,0),COLORBROWN;
STICKLINE(c>0,50,50,5,0),COLORYELLOW;
DMI:=SUM(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),11);
HC:=H-REF(H,1);
LC:=REF(L,1)-L;
DMP:=SUM(IF(HC>0 AND HC>LC,HC,0),11);
DMM:=SUM(IF(LC>0 AND LC>HC,LC,0),11);
PDI:=DMP*100/DMI;
MDI:=DMM*100/DMI;
ADX:=MA(ABS(MDI-PDI)/(MDI+PDI)*100,5);
ADXR:=EMA(ADX,5)+EMA((ADX-EMA(ADX,5))*0.618,5);
MPDI:=EMA(PDI,5),COLORRED;
助力:EMA(ADX,5),COLORWHITE;
助力系数:=助力/REF(助力,1);
波浪:EMA(ADXR,5),COLORCYAN;
fx:=MPDI+EMA((PDI-MPDI)*0.618,5);
方向:fx*助力系数,COLORRED;
判断:EMA(MDI,5),COLORGREEN;

通达信方向助力指标公式

 

相关文章